9
$\begingroup$

I would like to have thicker lines near camera and a lot of thinner in some range of distance from camera.

How can I achive this?

I tried 'Distance from camera' modifier (I tested all settings. Including "Invert" checkbox) and the only results I'm getting is the opposit effect: thicker lines far from camera and thinner near camera.

enter image description here

What should I do?

$\endgroup$
8
$\begingroup$

The Distance modifier scope is to control the line's thickness with its distance from camera. The main parameters are four:

  • Range Min: the distance of the camera's nearest object from the camera itself
  • Range Max: the distance of the camera's fartest object from the camera itself
  • Value Min: the bottom value of the graph
  • Value Max: the top value of the graph

enter image description here

The values

Notice that I'm talking about the graph and not the resulting thickness (that is the curve itself) because I would like to suggest that is not a good idea to set a Max value lower than the Min value.

The values should be defined in order to set up the graph (if you choose Linear insead of Curve you are just forcing the curve to be straight, but the concept is the same), then you can tweak the curve to get the desired result.

The range

To quickly get the correct Range Min&Max value you can use the built-in function Fill range by selection. Basilcally you'll just have to pick two object, push the button and you'll automatically have the fields filled up.

enter image description here

Once the four parameters are set up, you can focus on defining the curve. In your case you should draw a top to down strahight curve to get higher values at the beginning of the range and lower at its the end as shown in the image above.


If you would like to use the Linear option, you should activate the invert option in order to flip the straight curve.

enter image description here

enter image description here


Conclusions:

Start from filling the four parametrs with appropriate values.

In your case you left the default Range parameters (0-1000). I can't see the scale of your model, but I can guess that they are not appropriate. Give it a check.

Start from using very different Min Max values (e.g 1-50) to see the effect clearly and then lower them once you are sure that all works...

...and make sure the modifier is ENABLED FOR RENDER or you'll not see any of its cool effects! :)

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.