1
$\begingroup$

I am unable to separate all the loose parts of an object which I combined from several objects.

After combining all the objects, I removed doubles.

Now I want to separate the parts again to do some additional editing.

I used the following steps to try to separate the parts

  1. selected the object
  2. tabbed into edit mode
  3. clicked p
  4. clicked on "By loose Parts"
  5. tabbed back into object mode
  6. unselected everything with A
  7. clicked on part I wanted to edit and noticed two other parts were still connected.

I repeated the process of separating by loose parts, but they will not separate.

How can I disconnect the two side panels?

Not all parts are Separated by loose parts

I have highlighted the faces/vertices, I think might be causing the problem. When the file is opened they should be visible. At this stage all the components of the arm assembly are joined. When separated by loose parts the two side panels stay joined to the main arm.

Is it possible the problem occurs because I extruded the highlighted parts through the two side panels without cutting a hole in them first?

Thank you in advance for any suggestions you may have to help me solve this issue.

$\endgroup$
  • $\begingroup$ hard to say, could you please share your file? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Dec 30 '18 at 8:59
  • 2
    $\begingroup$ Removing doubles quite likely joined two parts. Consider copying the default cube, (no transforms) and joining. Separate by loose parts will return two cubes. Removing doubles will merge the two into one. $\endgroup$ – batFINGER Dec 31 '18 at 3:28
  • $\begingroup$ batFinger, thanks for the feedback. I thought that might have happened, but was hoping if intersecting vertices were removed they could be separated. At this point it may be easier to just recreat the objects unless some other option is posted here. $\endgroup$ – Claus Dec 31 '18 at 3:59
1
$\begingroup$

Well it's been about a week and with no real help here, I tinkered and finally came up with a solution. Deleting the connecting vertices between the side panels and the arm. There were two cylinders I had extruded from the arm through the side panels, which caused the problem.

Deleting the connecting vertices.

You can test yourself by using the sample file I uploaded here at moonboots request

  1. tab into object mode

  2. select object

  3. tab into edit mode

  4. select all faces

  5. click P and select "by loose parts"

  6. tab back to object mode

  7. deselect all

  8. select long arm and notice side panels are still connected

  9. tab into edit mode

  10. using faces select mode, press Alt and LMB to select all faces of first cylinder in the center of the arm.

  11. press Shift-Alt-LMB and select all center faces of 2nd cylinder

  12. press delete button and select vertices

  13. tab into object mode and deselect all

  14. verify side panels have been separated from arm by selecting each item

I now just had a few missing faces that needed to be filled in, but I preserved the location and size of all the pieces so they would fit in the model. Also I was able to finish the editing I needed to do, to prepare my model for 3D printing. You can verify how the assembly fits into the total model by clicking on the eye icon next to "frame" in the outliner.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.