0
$\begingroup$

I am having an issue where my audio is not being included with my final video file. Online it says to make sure there is an audio codec. So I have selected MP3 with my MPEG-4 video encoding. Still, it won't render with sound. The sound in the VSE is perfect.

What seems to be the issue? How do I render video with sound?

If it helps to know, I selected 9 FPS for the frames per second. This has not affected the VSE audio/video sync, so I would think that's okay.

.blend file

Render settings

$\endgroup$
2
$\begingroup$

I don't know why, but in your blend file (instead of screenshot) audio codec haven't selected . When I select it, everything is fine. Doublecheck this.

$\endgroup$
  • $\begingroup$ Odd, I double checked it and even tried different codecs. Thank you for your comment though. I have gotten iMovie and will use that just to add sound. $\endgroup$ – kaisa Dec 20 '18 at 8:52
0
$\begingroup$

Render your audio out separately using mixdown. It's to the right of your render button. Choose your audio settings. Change accuracy to something like 1 just to test. Confirm that the audio is correct in a DAW (audacity or something). A video player is less than ideal but that works too. If the audio isn't there still you should go to scene and check under audio the setting there. Make sure the proper channels are set, make sure the sample rate is correct as well, make sure master volume is not set to 0 or something weird. And hit update animation cache for good measure and try the render once more.

I can't comment on whether such a low fps has any bearing on this, it shouldn't. The fact you are using mp3 though could complicate matters though. I highly suggest you refrain from using mp3 unless its required. It's a proprietary format that is outdated and has been completely outclassed by its predecessor aac. For the sake of argument please test using a format other than mp3, I've had problems with it and blender in the past.

If you need more help with any part of that let me know.

$\endgroup$

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.