0
$\begingroup$

I'm having an audio and video out of sync issue that I don't have with version 2.79. I have created a new video project with Blender 3.0 VSE, in the composer I bring as input a video of 1920 * 1080 and 29.97 fps. This is a Sony camera file in MXF format (422 10-bit). I use the compositor to crop my subject from the green screen and I export the text to the MOV QT Animation format with the Alpha channel (19201080 29,97fps)*.

In a new project, I import my MOV file that I got with Blender. On a second track, I import the original video (MXF) to use the audio track. These two videos are with the same number of frames per second and are perfectly aligned. However, when one of the two video strips is turned on or off with the H key we notice on the monitor that the frames of the two videos are not synchronized and when I export the rendering, the sound is completely out of sync. I don't understand what's going on. With version 2.79 I don't have this problem.

The desynchronization problem appears when a video tape is turned on or off. The frames are not the same while the videos are perfectly aligned

$\endgroup$
2
  • $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Jan 18, 2022 at 14:49
  • $\begingroup$ Try re-building the proxy and timecode indices in the strip properties Proxy Settings tab. This should force Blender to accurately call the frames. Otherwise you should convert the media into a frame sequence as that is the only format that blender can guarantee to play correctly. $\endgroup$
    – 3pointedit
    Jun 6, 2022 at 0:02

1 Answer 1

0
$\begingroup$

Same problem here. Video and audio, when added, becomes out of sync. What I did to fix it (if you are adding more than one video to Blender, you'll need to do this for each video): I used handbrake (it is a free download) After opening Handbrake do the following: Open Source Choose your video and Drop your file Under Video, make your framerate 29.97 and (important) make sure you check the box below to make it Constant Framerate. Go down and "save as" to the folder you wish to place your video. This will save your audio and video at a constant framerate.Now, Add it to your Blender video as usual.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.