4
$\begingroup$

I can not get audio to play out of my speakers whilst using Blender 2.77a in the Video Sequence Editor. However when I rendered out a file (mp4) it contains the audio and can be played back on VLC. Plus when I use mediainfo it reports the file as having audio. I need to be able to hear the audio in the VSE whilst I'm editing the images.

When selecting Draw Waveform in the Sound menu a waveform is drawn on the clip that matches the audio (highs and lows are in the right place). Below is a screen shot of my Blender User Preferences.

User Preferences

I have tried all the Audio Device options under Sound but none of them have worked. Each time I changed the Audio Device options I restarted the computer.

Below is a screen shot of my Output and Encoding options from the Render menu.

Output and Encoding options

From some of the threads that I read some people were pointing towards sound card configurations. I am fairly new with using Blender so I am not aware of more advanced configuration options. I have spend one whole day trying to solve this problem by following similar post found via Google but have had no luck. If you need more information please ask.

Thanks very much.

System information:

  • Ubuntu 14.04 LTS
  • Blender 2.77a
$\endgroup$
4
$\begingroup$

To enable the sound in my Video Sequencing Editor, I had to change the system setting for audio device from OpenAL to SDL. Doing this seemed to jar loose the sound so that it would play. I was even able to change the setting back to OpenAL and the sound continued to be enabled. Strange, huh? The sound works fine now.

Go to File> User Preferences> System> Sound: Audio Device.

$\endgroup$
2
$\begingroup$

I have solved the problem. It was not a Blender issue it was an issue with the sound server (I think that is what it is called). I installed a program called pavucontrol which stands for PulseAudio Volume Control. This program enables the user to assign which audio device a program can be associated with. Below is a screen shot of pavucontrol being associated with Blender using the SDL option.

pavucontrol

In my case I choose Built-in Audio Analogue Stereo which works fine for me. With this selected I can now hear audio out of my speakers when I am in Blender.

I hope this can help someone. Thanks.

$\endgroup$
0
$\begingroup$

In the timeline window go to Playback > Audio Muted and disable that.

$\endgroup$
  • $\begingroup$ You may also want to turn on audio scrubbing, its very handy BTW $\endgroup$ – JakeD Aug 10 '16 at 15:12
  • $\begingroup$ Hello pycoder, Thanks for the response. I have tried Playback > Audio Muted checked and unchecked and either way I get no audio out my speakers. If have also tried Playback > Audio Scrubbing checked and unchecked and still no audio out of my speakers. Once again the sound clips do have audio present because when I render out a movie file it has the audio. Also as a test I placed keyframes onto the volume of the audio going up and down and the rendered out file played the audio with the volume going up and down where I placed the keyframes. $\endgroup$ – Lincoln Aug 10 '16 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.