1
$\begingroup$

I'm using Blender 2.79b on Fedora 28. When I go to render a scene I only have three options for direct video output. (AVI raw, AVI Jpeg, frame server). I have checked and re-checked I have ffmpeg installed with all codecs, I also have OGG lib's installed, neither of which show up. Any help getting Blender to detect other codecs would be greatly appreciated.

Thank you for your time and assistance.

Joe

Current codec options

$\endgroup$
4
  • $\begingroup$ have you tried creating a new blender file and checking the video output there? If it isn't I would assume there is something wrong with your blender. If it is there, well, copy and paste it over? Good luck with your project $\endgroup$ – Bigfoot Blondy Oct 29 '18 at 1:23
  • $\begingroup$ Check if you have ffmpeg installed on your system if not install it and that should provide you with more export options.. $\endgroup$ – Samir Rahamtalla Oct 29 '18 at 4:49
  • $\begingroup$ Thank you for the comments. Yes I tried a completely new file with the same results. I have also checked and re-checked and even reinstalled ffmpeg (a few times :). I guess I will try un-installing and re-installing blender. I will post the results here. Thank you again for your support. $\endgroup$ – JShel Oct 29 '18 at 20:11
  • 1
    $\begingroup$ Possible duplicate of How do I load an MP4 file with Blender 2.74 under Fedora? $\endgroup$ – brockmann Oct 29 '18 at 21:07
1
$\begingroup$

Problem solved!!! The Blender software provided by the Fedora repositories has an issue. After removing and re-installing the issue was still there. I then removed Blender via DNF and installed the package from the blender website and the issue is resolved. I now have ffmpeg and other codecs to render with. Thank you again for your support everyone. Joe

$\endgroup$
2
  • $\begingroup$ I should also add that I tested this one two different machine with the same results. I highly recommend installing directly from the package at blender.org if you are using Fedora. $\endgroup$ – JShel Oct 29 '18 at 21:21
  • $\begingroup$ It's a reported legal issue, see here: bugzilla.redhat.com/show_bug.cgi?id=1384180 TL;DR: "Blender requires ffmpeg which cannot be legally included in the Fedora repository." $\endgroup$ – dreua Dec 7 '18 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.