I'm trying to render a video using blender, it have some images and sound, if I render it using just the default options I get no sound.

Searching on internet I found that I need to use other format than AVI JPEG to set some codecs options, I just have "AVI JPEG", "AVI RAW" and "FRAME SERVER". I'm keep looking but I can't found any information to solve my problem.

Im using fedora and actually I have xvidcore-1.3.2-5.fc20.x86_64 ffmpeg-2.1.7-1.fc20.x86_64 packages installed.

EDIT: When I had the problem I had the last version of blender installed from blender download site, I also tried installing blender from dnf, also tried with buildbot, so this answer didn't solved my problem.

  • 1
    $\begingroup$ Blender is shipped with fedora, but without ffmpeg. Try downloading an official blender version from blender.org. $\endgroup$
    – p2or
    Jun 10, 2015 at 14:32
  • $\begingroup$ @poor at least my fedora doesn't come with blender, I have blender installed from the website. $\endgroup$
    – lcjury
    Jun 11, 2015 at 3:37
  • 1
    $\begingroup$ mmh, also using CentOs (rhel) here and I get this selection: i.stack.imgur.com/zqwE0.png - my os should be older than yours... weird. $\endgroup$
    – p2or
    Jun 11, 2015 at 9:50
  • 2
    $\begingroup$ Possible duplicate of How can I enable mp4/h264 as an output option? $\endgroup$
    – Samoth
    Feb 20, 2016 at 10:08
  • 1
    $\begingroup$ @lcjury Yeah, Linux and Packages... it doesn't always work like one would want... So you need to ensure, Blender is using the correct ffmpeg libraries. And that these support the codecs you want to use. Have you tried the buildbot Version mentionend by insaner below? But the usage of ffmpeg is buggy on Windows as well, so don't be too sad about your system. But maybe another Linux might work better with Blender. Didn't try it out myself yet as I need AviSynth with Blender on Windows with Pismo File Mount... $\endgroup$
    – Samoth
    Feb 20, 2016 at 20:20

4 Answers 4


Fedora ships blender with ffmpeg disabled for stupid legal reasons.

You can rebuild blender from the fedora source rpm with -DWITH_CODEC_FFMPEG:BOOL=ON as root as follows:

# cd /var/tmp
# dnf download blender --source
# rpmbuild --rebuild blender-*.src.rpm

The latter will most likely fail which is fine because that would be the one you already have. Install the BuildRequires:

# awk '/BuildRequires:/{print$2}' ~/rpmbuild/SPECS/blender.spec \
    | xargs -r dnf -y install

Enable ffmpeg, rebuild and install:

# rpmbuild -bb ~/rpmbuild/SPECS/blender.spec
# dnf reinstall ~/rpmbuild/RPMS/x86_64/blender-[0-9]*.x86_64.rpm

Now you have blender with matroska, h264 etc :)

Optionally versionlock your version:

# dnf install python-dnf-plugins-extras-versionlock
# dnf versionlock blender



I just ran into this same problem, and didn't see this question, someone else linked to it from mine. I too use fedora (fc17 in my case) and using the buildbot self-contained build (which you don't need to install, just unzip and run the blender executable) I got all the expected codecs showing up as options. I'm currently working on making a spec file to easily turn it into an rpm so you can install it via yum, rpm or whatever. I will update this answer once I've done that.

Hope that helps.


For you fedora users out there, I included the promised RPM .spec file in my answer to: How can I enable mp4/h264 as an output option? so you can package the standard binary builds from blender builder.

Please let me know if it helps any of you.


Blender from the fedora repository doesn't have that option.

In fedora 34 you can install Blender using flatpak. First you need to install the flathub remote

flatpak install flathub org.blender.Blender

There it does have the File format FFmpeg Video in the output properties. Now we can continue with cretaing a text animation with transparency.

As metaphor_set say if you install from the official website you must have installed FFmpeg in your operating system.

To install ffmpeg install RPMFusion repositories(both free and non-free) then run.

sudo dnf install ffmpeg
  • 1
    $\begingroup$ First thing to check: Is ffmpeg installed in the system. "rpm -qa | grep ffmpeg" should list what exactly is installed. If Blender doesn't find the binary, it doesn't list the option. $\endgroup$ Jul 11, 2021 at 14:22

With the pictures and sound in the VIDEO SEQUENCE EDITOR, In the Render Tab choose the following settings :

OUTPUT -> H.264
PRESET -> H.264
CODEC -> H.264

enter image description here

  • 1
    $\begingroup$ Have you read my question or I explained it wrong? "I just have "AVI JPEG", "AVI RAW" and "FRAME SERVER"". I don't have the output option "H.264" and I can't see the encoding menu. $\endgroup$
    – lcjury
    Apr 21, 2015 at 3:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .