0
$\begingroup$

So i updated my blender to the latest version in both windows and linux.

Both immediately shutdown after the initial pop up.

Ran from console in Fedora 28

**found bundled python: /home/xxxx/Downloads/blender-2.79b-linux-glibc219-x86_64/2.79/python
X server found. dri2 connection failed! 
DRM_IOCTL_I915_GEM_APERTURE failed: Invalid argument
Assuming 131072kB available aperture size.
May lead to reduced performance or incorrect rendering.
get chip id failed: -1 [22]
param: 4, val: 0
: CommandLine Error: Option 'enable-value-profiling' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options**

Any idea's?

PC -

AMD FX-8350 Nvidia 970gtx 32gb DDR3

Windows 10 & Fedora 28 on gnome

Any help would be greatly appreciated!

$\endgroup$
  • $\begingroup$ The fact it isn’t working on both Windows and Linux would imply something common to both - eg, an add-on that you’ve previously had installed that is no longer compatible. You could try locating your blender user settings directory and deleting it (best to move it out of the way rather than actually delete it since you can then put it back if you need it). Once it’s deleted you should be back to ‘factory defaults’. $\endgroup$ – Rich Sedman Aug 24 '18 at 15:40
  • $\begingroup$ Thanks... I'll give that a go for windows... I reinstalled linux.. Changed to Elementary OS which even auto detected my gfx card! Blenders running nicely now! $\endgroup$ – Shugs81 Aug 25 '18 at 16:07
0
$\begingroup$

tl;dr : If you have an AMD GPU, try uninstalling beignet.

I was getting the same Command Line error on Fedora 28 \w XFCE. Found a thread at https://askbot.fedoraproject.org/en/question/121807/how-fix-blender-and-run-on-fedora-28/ (archived from ask.fedoraproject.org) suggesting removal of the application 'beignet'. Checking my repo, I found that beignet is for running OpenCL programs on Intel GPUs and that it was installed. However, mine is an AMD GPU. Uninstalling the unnecessary beignet application resolved the problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.