6
$\begingroup$

In the Properties -- World tab, I am no longer seeing the "Stars" option. Has it been removed or did I accidentally do something silly that caused it to be deleted or completely hidden? It is completely absent not just closed, and I have tried with several different files and a new restart.

I am running on Manjaro Linux and the blender version currently installed is 10:2.69.a0dbee6e. I'm not sure of the change occurred at the last upgrade or since then.

$\endgroup$
9
$\begingroup$

Stars feature has been dropped from Blender Internal render engine. See here. However, the official release 2.69 still has it. You can either choose that version, or find another way to get the same result.

$\endgroup$
  • $\begingroup$ It's a shame this 3D feature has been dropped: it was wonderful to have and use it and also was easy to use and intuitive. It needed just some more feature and possible setups, but dropping it, well it's a deep shame! I now like less blender for this wrong choice! Could we hope this feature will come back in future? $\endgroup$ – willy wonka May 1 '18 at 12:34
5
$\begingroup$

Like Leon said, Blender Render Internal no longer supports simple checkbox, but it does support adding a Stucci Texture that is really easy to do and does the same thing as the checkbox, but gives you a bit more control over the stars. This method has one drawback as far as I can tell - if you use he Mist checkbox, the stars appear in the mist and can overlay your scene with stars.

This video shows how to add the Stucci Texture to the World: https://www.youtube.com/watch?feature=player_embedded&v=sb4ryQMvRi4

$\endgroup$
  • $\begingroup$ Yes but it isn't a 3D stars field, it is just a background, for example you cant fly trough it as was possible before. The texture is less intuitive to set up and less realistic. The dropped star function was awesome instead. $\endgroup$ – willy wonka May 1 '18 at 12:34
2
$\begingroup$

The starfield generation feature is only accessible when you use the Blender Internal render engine.

When using Cycles render engine, it's unavailable.

Make sure the render engine is set to Blender Internal, and go to World panel.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.