0
$\begingroup$

Yay, a new version. More confounding behavior? You betcha.

I have a scene set with my Sky Texture (in the World Nodes) having a bunch of settings that help me set the scene. Among those, a Sun Elevation of 10 Degrees. However, the second I hit the F12 key to render my scene, the value of Sun Elevation snaps right back to 81.6 Degrees. Every time. I have no idea why it's happening and no idea how to stop it.

In addition, for whatever reason, when I initially set my World with the Nishita texture, the lighting is so completely blown out that I lose all shadows. It's like the sun is exploding. This persists even when the Background strength is 0.100. I've had it down toward the floor and it still looks terrible.

I realize I can wait for some really explanatory tutorial about this, but I've already watched a few from when this was in beta and it all appears quite straightforward. My results, so far, have been disappointing.

Thanks for your attention.

UPDATE

Here is what my Cycles preview of this rando scene looks like.

And simple nodes, too

Note the low values for Sun Elevation & Sun Intensity. I've been aiming at a morning/evening depiction.

For the record, I actually managed to get this working, but then I tried to incorporate an HDRI and ended up back at square 1.

Additional Edit: Now it's resetting to 82 Degrees, not 81.6. In case that matters...

$\endgroup$
4
  • $\begingroup$ Are you using the "Sun Disc"? $\endgroup$ Sep 1 '20 at 4:48
  • $\begingroup$ Yes. I am. But it appears not to matter... $\endgroup$ Sep 1 '20 at 16:12
  • 1
    $\begingroup$ You've likely enabled the Sun Position add-on, which is responsible for resetting the position. See ticket T78618. $\endgroup$
    – Robert Gützkow
    Sep 1 '20 at 17:32
  • $\begingroup$ THANK YOU. That cleanly solves the problem. Adjusting the other settings, I've found my shadows have come back. $\endgroup$ Sep 1 '20 at 17:49
2
$\begingroup$

This is a common problem caused by the Sun Position add-on, which takes control over these properties. Try to disable it and you should be able to change the values. The issue has been previously report on the bug tracker in ticket T78618.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.