4
$\begingroup$

This question already has an answer here:

Is there a way to make a smooth shaded mesh look like the third column in this example? The six sides of the cube should have their vertex normals aligned with the face normal.

Here is what I've tried so far:

  1. Beveled, smooth shaded (faces are not flat)
  2. beveled, smooth shaded, edge split (faces aren't joined)
  3. Modified in external application (faces are flat, bevels are smooth)

Example

$\endgroup$

marked as duplicate by p2or, Ray Mairlot, VRM, cegaton, David Oct 8 '15 at 18:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 5
    $\begingroup$ Possible dupe blender.stackexchange.com/q/734/12 $\endgroup$ – iKlsR Oct 8 '15 at 8:15
  • $\begingroup$ @iKlsR Even following the suggestions in that question I can't seem to get a result like the OP's third example here. $\endgroup$ – gandalf3 Nov 11 '15 at 4:16
  • $\begingroup$ @gandalf3 First seems to be just smooth shaded. second is smooth with bottom flat third is smoothed with some supporting loops added? $\endgroup$ – iKlsR Nov 11 '15 at 4:18
  • $\begingroup$ @iKlsR Ah, that makes sense. I got the impression that it was somehow set up without additional geometry, but I'm not sure how that would work (does blender support importing custom normals?) $\endgroup$ – gandalf3 Nov 11 '15 at 6:52
  • $\begingroup$ The third one was actually modified with scripting to set the vertex normals to the surface normal the currently selected face. This is intended to be used in a game so less geometry is better $\endgroup$ – Ryan S Nov 12 '15 at 4:59
1
$\begingroup$

If I got your question right, I think you should use a "subdivision surface" modifier, and smooth shading, to get what you want. Just add some edge on the cylinder top face and side surface, quite near the loop that divides them...

See below images:

enter image description here enter image description here

or, for the cube version: enter image description here enter image description here

$\endgroup$
1
$\begingroup$

I believe you just need to enable Object Data > Auto Smooth, then set it to a value less than 90°.

Enable Auto Smooth

Seems to give the proper results when bevelled:

enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.