0
$\begingroup$

I have this happening with my mesh with smooth shading:

enter image description here

The center vertex is crooked even though all of its neighboring faces are pointed in the same direction. This pattern continues across a whole face-loop and creates a long crease between these faces.

I thought that smooth shading was supposed to create the vertex normal by averaging its neighbors' faces, so I'm not sure why this is happening. In flat shading it looks completely flat.

I've tried recalculating the normals.

$\endgroup$
  • 1
    $\begingroup$ Do you mind uploading the .blend file? $\endgroup$ – Abraham Mast Jan 31 '16 at 3:53
  • $\begingroup$ does the normal get back to original when using flat shading ? $\endgroup$ – Yvain Jan 31 '16 at 9:20
1
$\begingroup$

Sometimes this happens for no apparent reasons. I have gotten into the same issue several times when importing models from other 3d packages. The only way to quickly remove them if apply normals and smooth shading doesn't work, is to ....

  1. Delete the faces only, around the affected vertice and the edges undeleted.
  2. Hit X to delete and choose "face only".
  3. Turn on F2 add-on in the user preferences.
  4. Select adjacent edges and hit F, to fill it with a face between them.

You should now how a clean mesh with the correct normals.

Note Only use this method if Ctrl + N and applying smooth shading on the model does not solve the problem

.

$\endgroup$
  • $\begingroup$ Thanks, this was helpful and seemed to fix most of the symptoms. But it turns out the root cause was hidden faces on the inside of the mesh. $\endgroup$ – Ryan Jan 31 '16 at 18:00
0
$\begingroup$

It turns out there were more faces adjacent to the vertex hidden inside of the mesh. Deleting these solved the problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.