9
$\begingroup$

The machine that I'm currently using is an extremely slow netbook. Whenever I go to change user preferences in Blender, it stalls out. What I need to do is activate the "emulate 3 button mouse" checkbox. Is there a way to do this via console/script?

$\endgroup$
  • $\begingroup$ try experimenting with bpy.context.user_preferences, use Ctrl + Space to autocomplete.. $\endgroup$ – iKlsR May 24 '13 at 16:30
  • 1
    $\begingroup$ If your computer has problems with the 'preferences' menu, how does it manage rendering? $\endgroup$ – Gwen May 24 '13 at 18:19
  • $\begingroup$ @Gwenn it can do it, but pretty slowly. It can even do Cycles. I'm not sure why the preferences menu doesn't work on it. $\endgroup$ – Daniel Pendergast May 24 '13 at 18:41
  • 3
    $\begingroup$ If you open the user preferences in a new window, that might slow down a netbook. Instead, try opening the user preferences in the 3dview. And to make sure nothing slows unnecessarily down: don't render in new window or fullscreen, but in existing image editor (make it small). $\endgroup$ – jesterKing May 24 '13 at 20:52
8
$\begingroup$

Got it.

bpy.context.user_preferences.inputs.use_mouse_emulate_3_button = True

It also says on the wiki that The Blender API can modify user preferences, keymaps and themes

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.