1
$\begingroup$

I'm getting some error and cannot open my User Preferences window anymore.

I was doing some Python addon development (nothing fancy, just iterating through objects), loading and unloading my addon and at some point I must have killed the User Preferences window. Now when I try to open it by selecting File > User Preferences, a popup displays "Failed to open window!". The console displays:

Win32 Error# (3221692624): <no system message>

I've tried restarting my computer, but that didn't help. I've also tried deleting my script from C:\Users\&lt;user&gt;\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons.

What can I do to restore my User Preferences window?

$\endgroup$
3
  • $\begingroup$ Have you tried to move your addon file so they will not be loaded anymore? $\endgroup$
    – Dimali
    Apr 7 '17 at 23:08
  • $\begingroup$ Yes, I deleted it from my Blender home scripts directory. Didn't help. $\endgroup$
    – kitfox
    Apr 7 '17 at 23:48
  • $\begingroup$ Just reinstsalled Blender too. Didn't help. $\endgroup$
    – kitfox
    Apr 8 '17 at 0:03
1
$\begingroup$

Okay, I just did a full uninstall followed by a reinstall and toasting my Blender user directory. The User Preferences will open now.

$\endgroup$
2
  • 1
    $\begingroup$ User preference does breakdown after a number of attempt at reloading. It's common when testing scripts. Don't do anything, just restart blender, and it usually comes back alright. Unless you've been doing something terribly wrong that it breaks your installation of blender altogether. $\endgroup$
    – TeaCrab
    Jun 30 '17 at 0:25
  • 1
    $\begingroup$ This is not an acceptable way for Blender to behave. If you can reproduce this issue with the latest version of Blender, please report it as a bug at developer.blender.org $\endgroup$
    – dr. Sybren
    Oct 8 '17 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.