I've been trying to track a shot in Blender that I'm adding VFX to. The footage was shot on a 35mm lens on a tripod with a loose head. Because the shot only moves a small amount, the track points are very easy, but where I run into a problem is when I go to "solve camera motion". My 3d camera is set to a 35mm focal length to match my footage, but every time I hit "solve camera motion" blender automatically changes the focal length to about 24mm or 25mm, even if I don't tell it to solve the camera's focal length. It changes it regardless of what "refine" setting I select: "Nothing"..."K1,K"2..."Focal Length, Optical center"....etc. I do have the "tripod" selection checked.

Manually changing the 3D camera's focal length back to 35mm after the fact just throws my track off.

To make matters more complexing, I discovered that if I press the "solve camera motion" button multiple times, the focal length actually increases slightly each time. I can press the button over and over and the focal length ticks up like .4 or .5 mm in every time, which is completely bizarre. The track holds throughout this process, so I pressed the button a ton of times and actually got it pretty close to my 35mm focal length goal. But obviously this is not the way it's supposed to work, and I can't figure out a way to lower the focal length again either if I wanted to.

I'm currently working in version 2.90, but I installed the newest version to see if that improved anything -- unfortunately it did not.

Any thoughts one what might be going on here would be greatly appreciated! Thank you!


It sounds like you probably have your movie clip set to the default focal length of 24mm:

enter image description here

Blender will of course set your camera to match your movie clip when you run the track, or else the track won't make any sense.

The focal length converges on 35mm after running multiple tracks as Blender eventually figures out that the 24mm setting you've provided it is incorrect.

  • $\begingroup$ Oh wow -- I didn't even realize that panel existed. I think this might be exactly my problem. Thank you very much for your help! $\endgroup$
    – Danny
    May 20 '21 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.