3
$\begingroup$

I am stuck in quite a situation. I had to track a footage shot with a fisheye lens @ 8mm ( 8-15 f/4 canon fisheye ) attached to a red-epic camera. The footage also has its optical centre shifted quite a bit in Y and slightly in X. This with the amount of distortion on the footage made me think that the footage would be untrackable.

It is a shot of a helicopter flyover a landscape for a ride film. There is no lens chart shot for this.

However to my surprise, blender solved the camera nicely. It also calculated the focal, distortion( polynomial with k1 and k2 ), optical centre values (movie clip > properties bar > camera Panel> ).

blender gave a descent solve with the 3d locators almost sticking. The undistorted footage looks correct when I generate the undistorted proxies. The locators stick to this undistorted footage. However, when I used the movie distortion node in the compositor set to undistort, the distortion comes out different compared to undistorted proxy that blender generated. I think that it is not considering the shift in the optical centre?

How Can I solve this issue? I tried to use the translate as well as transform nodes before attaching the movie clip to distort node in the compositor, but got no luck.

Unfortunately I cannot share the screenshot images as I am in office and NDAs.

Here are the camera values in MovieClipEditor. Footage size : 4752x3160 , 1360 frames Camera Sensor Width : 30.00 Optical centre : x = 2401.30, y = 2241.951 Focal length : 14.35 Distortion values : k1 = -.231, k2 = .029, k3 = 0.0 Solve error = 9.33 ( Believe me, it good for the footage. I plan to refine it further. )

3d View camera values : under camera > lens > shift X = -.005, shift Y = -.139 focal : 14.35

Thank you for reading this long post and any help/ advice.

$\endgroup$
  • $\begingroup$ Are the scene frame dimensions the same as those of the original frame? Please post an image of your node setup $\endgroup$ – cegaton Jun 21 '16 at 23:43
  • $\begingroup$ 9.33 pixels is still to high for a solve error... $\endgroup$ – cegaton Jun 21 '16 at 23:45
1
$\begingroup$

thanks for the reply :)

I actually did manage to get the distortion working properly. :) My mistake was that I had hit the "centre" button( Movie Clip Editor > Properties panel > camera > centre ) after solving and that was throwing the undistort node off in the compositor.

Setting the correct values again in the "centre" panel fixed it.

I cannot post the images here as "uploading" is blocked in my office due to security reasons.

The high error values I will solve later in another proprietery software @my office. Its awesome.

Thanks, Jayraj

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.