1
$\begingroup$

First and foremost, I am on 64bit Windows 10, V1909, Build 18363.1440
My current blender installation is 64bit 2.92.0, fresh from blender.org

When I click on the primitives while in Grease Pencil's Draw view, they do not activate. When hovered over, it says they're throwing an Internal Error,
In the Info view, that error appears to be:

Python: get_rna_type("gpencil.primitive") not found
location: <unkown location>:-1

In the system console, it appears to be:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "C:\Program Files\Blender Foundation\Blender 2.92\2.92\scripts\startup\bl_ui\space_toolsystem_common.py", line 1090, in description_from_id
    return tip_(_bpy.ops.get_rna_type(operator).description)
KeyError: 'get_rna_type("gpencil.primitive") not found'
Python: get_rna_type("gpencil.primitive") not found
location: <unknown location>:-1

Each of the 6 primitives (line, polyline, arc, curve, box, circle) throw this error when hovered over.
No error is thrown when selecting or using the tools.
All errors are from a new file in 2.92.0

This has been happening since I installed 2.80, so I imagine this is a problem with my PC or installation, but I don't know what could be causing it. It did not occur prior to installing 2.80 - but that was very long ago at this point.

I've tried:

  • using a clean installation of 2.78, 2.79, 2.80, 2.82, 2.83, 2.90, 2.91, 2.92
  • repairing existing installations of 2.82, 2.90 and 2.92 via the installer
  • manually replacing ops.gpencil.primitive files with the files available on github

It hasn't bothered me before, so I've never looked into it, but now that I am doing my own concept sketches, I sorely miss the circle tool.

If anyone has an idea on what I could do to repair this issue, I would greatly appreciate the help.

$\endgroup$
0
$\begingroup$

After some messing about, I deleted my user preferences to find that it solved the issue.
Unsatisfied with this catch-all fix, I endeavored to find out why, and went through each setting, enabling and disabling it to see its effect.

It turns out that my keymap, being the same keymap I've been using for, perhaps years, still being retained through to 2.92, somewhat customized, caused the issue.
I do not know why, or how, but not using it seems to fix the issue entirely.
Perhaps there are some formatting issues, as clearly my old keymap file does not load the same Preferences menu that the new default ones do.
It also seems that it doesn't know what about itself has been changed, as it marks parts of the keymap as being able to be restored, when I did not change those parts. Perhaps the keymap is corrupted.

I have no idea how the keymap having problems would affect the ability of the tools to function, but apparently it does.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.