3
$\begingroup$

I used to have a shortcut to toggle 'Display Only' option in 2.7 but in 2.8 that no longer works and I have to click the 'Display Overlays' button manually which is annoying. Does anyone know how to setup a keyboard shortcut like that?

$\endgroup$
  • $\begingroup$ Was just a short-lived bug, it seems. I assigned a hotkey for this via the context (right-click) menu recently. Don't know when the fix came in but it's no later than 6/4/19 (date of my current build). $\endgroup$ – B Layer Jun 11 at 4:49
4
$\begingroup$

I got it, you need to set up a hotkey manually, this is not accessible from the right-click menu:

  • Hit F4 to get to the Settings Menu and go to Keymap
  • Open 3D View > 3D View (Global)
  • Scroll to the bottom and hit the + Add New Button, to add a new Key-Binding
  • Enter wm.context_toggle in the Context Field
  • The Context Attribute Field will now appear. Set it to space_data.overlay.show_overlays
  • Don't forget to save your Hotkey Settings

Settings to set up a Custom Hotkey for Overlay Toggle

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.