1
$\begingroup$

I attempted to use Blender again today on my Linux machine and see that it's now up to version 3.5.1 and it looks very nice compared to the 2.90 I last used. However, one interface change I don't care for is that the main window background now appears to be semi-transparent with the default settings (Load Factory Preferences was used). In some circumstances this might be useful and it may even be that I did this the last time I used Blender, but I can't figure out how to change the background to what I remember (and prefer) which is a solid gray background.

I did search in Edit->Preferences->Themes where there are a large number of colors, but nothing that seemed to affect this. I also did internet searches including here, but if one searches for "Blender transparent background" it yields a great deal of information, but none is relevant to this particular question.

Since a picture is worth a thousand words, here's a picture of Blender running on my machine. In the background is a browser window rendering the main screen of a popular search engine, but in this screen shot, Blender currently has focus and I would prefer not to see what's "behind" it.

Blender screen shot showing transparent main window

Machine and Environment Details:

The machine is a 64-bit i9 box running Fedora 38 (Linux kernel 6.3.12) and Blender 3.5.1 with the Wayland compositor and nouveau video driver driving a NVIDIA Corporation GP104 [GeForce GTX 1060 6GB] graphics card with dual monitors.

$\endgroup$
3
  • 1
    $\begingroup$ That looks like a graphics driver problem (or possibly a Linux setting?). $\endgroup$
    – John Eason
    Jul 27, 2023 at 18:35
  • 1
    $\begingroup$ Similar question here: blender.stackexchange.com/questions/297394/… $\endgroup$
    – taiyo
    Jul 27, 2023 at 18:45
  • $\begingroup$ Both of these were useful comments that helped guide me to a solution. Thank you. $\endgroup$
    – Edward
    Jul 27, 2023 at 22:30

1 Answer 1

1
$\begingroup$

The problem

This is apparently a video driver problem. The person who asked the question linked in the comment submitted a bug report: https://projects.blender.org/blender/blender/issues/110327

However, that bug was closed with a somewhat confusing response:

Listed this report from #76428 however nouveau drivers are known to have many limitations compared with NVidia's drivers.

Closing this report as NVidia's drivers having poor (even broken) Wayland support is also out of our control.

So apparently neither the nouveau driver nor the proprietary alternative driver work. The reporter of this problem provided a useful summary of the current state of affairs:

After trying out the proprietary driver, the issue does not occur! However; pretty much everything else surrounding blender breaks. Most wayland compositors straight up refuse to boot off of nvidia instead of nouveau. I got Plasma to work with nvidia and tested it that way; but everything was so slow that it was basically unusable. (There were 3 seconds between me moving my mouse and it updating on screen).

So while Blender might work better with proprietary drivers, wayland seems to very much not; or so says my experience.

So users of NVidia cards under Linux seem to have a problem until either the open source nouveau driver or the proprietary NVidia are improved.

Solution

One way to get it to work is suggested in the troubleshooting section of the Blender documentation website. This is what worked for me to start Blender from the command line:

WAYLAND_DISPLAY="" blender

That has the effect of disabling Wayland (and some associated features such as smooth scrolling for trackpad input) but allows Blender to run without the distracting backgrounds of other running applications.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .