trying to install grpcio and grpcio_tools (v 1.38.0) using pip. This is what i'm running in the terminal and the output i'm getting

C:\Program Files\Blender Foundation\Blender 3.3\3.3\python\bin>python.exe -m pip install --no-cache-dir grpcio==1.38.0
Collecting grpcio==1.38.0
  Downloading grpcio-1.38.0.tar.gz (21.4 MB)
     ---------------------------------------- 21.4/21.4 MB 54.7 MB/s eta 0:00:00
  Preparing metadata (setup.py) ... done
Requirement already satisfied: six>=1.5.2 in c:\program files\blender foundation\blender 3.3\3.3\python\lib\site-packages (from grpcio==1.38.0) (1.16.0)
Building wheels for collected packages: grpcio
  Building wheel for grpcio (setup.py) ... /

It gets stuck building for a while, then it fails (timeout).

I've upgraded pip, setuptools, made sure everything is coherent and dependencies are OK. I forced installation (no cache). I tried to install other versions, nada.

i'm running the default python that comes with blender 3.3 (3.10.2 to be exact). Tried uninstalling blender (and deleting the python directories since they're not removed by default), reinstalling blender (and python by concequence), still nothing.

would appreciate the help! Cheers

  • $\begingroup$ i have the same error . i have no way to solve it . $\endgroup$
    – yu chen
    Feb 15 at 18:49
  • $\begingroup$ Apparently, this specific version didn't work. Simply pip install grpcio and get the latest version. That's what i did. $\endgroup$
    – OmarS
    Feb 16 at 19:19

1 Answer 1


i have solved it .

  1. create a new python env by anaconda or pyenv;
  2. pip install grpcio ,it will take some time ;
  3. go back to python and use blender python.exe to install grpcio; i dont know why ,but it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .