1
$\begingroup$

I use a dual monitor set up (Dell as primary monitor, Wacom Cintiq as my secondary). I want blender to start up on my secondary monitor. Manually moving the Blender window to my secondary and saving the preferences doesn't seem to solve this. It still always opens on the primary monitor.

In addition to that, I want the "Preferences" and "Save/Load" pop up menus to also open on my secondary monitor. It always pops up on my primary monitor, and the size of the window changes each time which is doubly frustrating. It completely kills my workflow to have to toggle my wacom pen between monitors, look over to the other monitor to select something, then toggle my wacom pen back to the secondary monitor.

Thanks in advance for your help!

$\endgroup$
1

4 Answers 4

3
$\begingroup$

Try creating a new project, setting the all the windows as you want them to be and save it as your startup file. This can be achieved by going to File > Defaults > Save Startup File. I use this so Blender starts in both my monitors, but I see no reason why it woudn't work in your case. Hope it helps.

$\endgroup$
1
  • $\begingroup$ Thanks for your suggestion! It worked for the main window, but the Preferences and Save/Load dialogue box still opens on the unwanted monitor. Any ideas how to resolve that? $\endgroup$
    – h_sharp327
    Jul 6, 2020 at 23:09
1
$\begingroup$

This also works: on your shortcut icon under the shortcut tab, right after the quotation mark in the target section, enter these perimeters: -p 1600 0 1920 1080 You can change the last 2 set of numbers to your second monitor’s dimensions. It should now load on the second monitor.

Add a -M to the end to get the window to load maximized, or -W to make it load full screen.

Detailed explanation here: https://www.christoph-werner.de/2015/08/28/hint-start-blender-on-a-second-display/

$\endgroup$
1
$\begingroup$

On the top menu use Window > New Window

Drag new window to second monitor and configure how you want it. Make sure every time you close the project you close it on the main/original window and not the secondary window, because otherwise it will just close that window and the project will remain open.

One of the things I really hope they update is making dual monitor setups more intuitive.

$\endgroup$
1
  • $\begingroup$ If you are going to use this configuration permanently, then save the project as default with File > Defauts > Save Startup File. Also note that for this to work the Load UI option has to be enabled in the blender preferences Save and Load section. $\endgroup$
    – susu
    Jan 24, 2021 at 6:32
0
$\begingroup$

I am using two monitors, the main is 3840X2160, the second is 1600x1200 Wacom and mine are setup so the second monitor is on the left of the first. I have it on extended displays and only show the desktop icons on the first monitor by making it the main display. My extra settings to open Blender on the second monitor are: -p -1600 1 1600 1200.

I found the 1 will activate the app after loading.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.