4
$\begingroup$

I started having an issue a few days ago with Blender. When starting up the program it runs the console and it never goes away, it stays like the image. I can still use the program, but i don't know why this is happening. Any solution? Image of the console

$\endgroup$

2 Answers 2

3
$\begingroup$

The previous answer to this question did not work for me, but this does.

Go into Windows settings > Privacy & Security > For Developers > Terminal and in the drop down menu change from "Let Windows decide" to "Windows Console Host"

enter image description here

$\endgroup$
2
  • 2
    $\begingroup$ Thanks a lot for this! It solved my issue $\endgroup$ May 5, 2023 at 12:28
  • $\begingroup$ Thanks, solved! I use the new Windows Terminal, and this setting can also be changed in-app: Settings -> Startup -> Default terminal application -> Windows Console Host -> Save. Blender console now disappears after blender.exe launch is complete! $\endgroup$ Nov 8, 2023 at 3:26
8
$\begingroup$

Same here, since a few days – due to a Windows 11 update, I think.

Anyway, to start Blender without the console, you can run blender-launcher.exe. It's in the same directory as your blender.exe.

$\endgroup$
3
  • 1
    $\begingroup$ Thankls a lot! That worked $\endgroup$ Nov 11, 2022 at 23:15
  • $\begingroup$ Don't forget to click the ✅ next to that post to mark it as the right answer to your question. $\endgroup$
    – L0Lock
    Nov 17, 2022 at 17:26
  • $\begingroup$ This is awesome to know, thanks! The only downside: if you want to keep Blender pinned to your taskbar, you'll have to pin blender-launcher.exe which will result in a duplicate blender icon once Blender is launched and running. $\endgroup$ Nov 8, 2023 at 3:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .