9

For bones that you don't want to deform the mesh, uncheck deform in the Deform Panel of bone properties.


7

I am not quite sure(I would have to go under several more trials) but I think I solved it. It can be achived by Switching the Fall off type to Custom Curve and let the Curve always be 1. As for Default weight, set it to 0. EDIT: I managed to get this right so I would like to share the techniques to edit your VERTEX WEIGHT with TEXTURES. First, I would ...


5

I made two small changes to your script that might help it work as intended. I switched to using bmesh to save the selected verts data. I find it a bit more reliable and stable than the built in mesh data. I saved the vertex indices instead of references to the vertices themselves in the list comprehension. This makes sure the list, which is comprised of ...


4

You could use cloth physics for the deformation part. Pin the corners or edges of the rubber object so it keeps its shape by adding it to a Vertex Group. Let the physics do the rest. Not sure how one could do the holes. Weight Proximity could help fake it, I don't think there is any elegant solution with Blender. You can also assign each hole size to a ...


3

While the answer is in Blender's API docs, the relationships aren't clearly spelt out so you need to "get" some of the relationships to know how it fits together. An armature can get confusing, there are EditBones that define the armature that you see in edit mode. Then you have PoseBones that are used when posing the bones in an animation. You access ...


3

You want to be in Weight Paint Mode. From there, goto Weights >> Clean. The settings for which threshold you want (if its other than zero) can be found on the tool shelf, on the Clean Vertex group Properties.


3

It sounds to me like you're looking for the Hook modifier.


2

It seems you have a common misconception about how bone deformation weighting is calculated. The way it actually works is as follows: If a vertex belongs to one or more vertex groups which are parented to bones, that vertex's bone-deformed location will be equally split between the bones' locations according to the ratio of their respective weights. The ...


2

You have got multiple problem with your model. Your Character's head has half an extra meshes with the mirror modifier. I select the extra vertices and deleted them. You have overlapping faces on within the model. I removed the extra faces with W key, then select "remove double" The body of your character have normals facing in the opposite direction. I ...


2

The data transfer function may help you. You will have to set your two objects as they overlap. Then use the "data" button in the "Data transfer" section. Then choose "vertex groups" as shown here And then go to the operator options (bottom part of the first image here). You can then choose de source : probably your group name. Then the destination : "...


2

Blender does not currently support anything like implicit skinning, or any dedicated tools for character self collision. Dual Quaternions are simply a different way of calculating bone transforms on vertices and prevent some artefacts, but have no concept of intersection or volume (although they make the results appear to preserve volume better under some ...


2

If that can save you some time. See the commented part below: bl_info = { "name": "Quickly set weights of Vertex Groups", "author": "nicmar", "version": (1, 0), "blender": (2, 78, 0), "location": "Properties Editor > Object data > Vertex Groups", "description": "Quickly set Vertex Groups with assigned weight and live edit", ...


2

Vertex Weight will only appear after the weight has been assigned a vertex group. In my example you will see it appear after I add some weight paint which automatically creates a vertex group. If you select more vertices that include vertices without a vertex group it will disappear from the properties window again. [I admit I find this confusing behavior]


2

For the vertex weights panel (not to be confused with the vertex groups panel) to appear, you need to be in vertex select mode in edit mode and have a vertex that is associated with one or more vertex groups as the active selection. It should then appear on the 'N' panel. For more info for others (the question quotes the manual): https://www.blender.org/...


2

The 3D view is the view you normally work in when modelling. I assume that's what you mean by default view. The Vertex Weights can be found in the Vertex Groups when in Edit mode and if you enable the Vertex selection masking it's also available in Weight Paint mode. To enable Vertex selection masking, click the icon that is marked in the image ...


2

I suggested projected face interpolated in the comments, but in your case "nearest face interpolated" works better. The reason is 'projected' projects along faces normals and in your case, some faces normals does not point to the base mesh. Here is your file back: Note: Often, data transfer has to be tuned, and so you need to retry often. That's why I ...


2

Object Mode Version Here is a test script to run in object mode. It looks for all vertex groups on active object that end with ".L", finds a matching group ending with ".R" (or None). Then using the list comprehension methods from Python - Finding Vertices in a Vertex Group check if there are the same number in each. If so, for each left group vert, sort ...


2

Not a direct answer to your question, but you can also use both procedural and image textures to drive the length of your grass: Hair_Length_by_Image_Texture.blend More info here.


2

This code is convert into Blender 2.8 for now, in any 3D view mode, you can find the option in 3DVIEW properties panel. If the object you selected have a vertex group, it will reveal those vertices with their weight (round to 0.01 for readability) You should start work on the bgl and blf module for more tuning. That's what the original coder use. bl_info = ...


2

The Blender default color pattern for weight painting is bad. Nearly not weighted vertices displays as blue. But not weighted vertices displays also as blue. In the Viewport Overlay options in the Weight Paint section turn the Zero Weights display from None to Active. That way the not weighted vertices will display black. And so you can see the trouble ...


2

You need to enable the 2D Falloff option, in the 3D View N panel > Tool tab > Brush > Options or in the Properties panel > Active Tool tab > Brush > Options. Also disable the Front Faces Only option.


1

There is a way that you can setup your screen to make it faster: Try adding the vertex group to the Solidify modifier and set the max thickness. Then you can either select some vertices and set the number directly or go into weight paint mode and paint in thickness.


1

if the model already has weights, it should have vertex groups. Make sure the bones in your rig are named the same as the existing vertex groups. Then select the model, then the rig, and hit Ctrl-P > Armature Deform (and make sure the armature modifier on the mesh is set to Bind to Vertex Groups). If you have additional bones that you want to use that don't ...


1

Try switch 'Show Zero Weights' to none ...at least to get rid of the black. I think 'Clean' might be confusing the issue... I can't see your brush settings but I paint with auto - normalize on, and find 'Smooth' the most useful of the Weight Tools for fixing. The manual itself is also full of good info.


1

Select your Mesh and delete all vertex groups and all modifiers as shown: Select your Mesh then select your armature using Shift+RightClick and hit Ctrl+P then choose With Empty Groups: Switch to Pose Mode then select the two bones LWrist and LShoulder then select the mesh using Shift+RightClick as shown below: Switch to weight painting mode and select ...


1

The rig hierarchy will not affect the results, you should only need to correct the weighting if you move the bone. The mathematics behind this effectively first transforms each each vertex by each bone that it is weighted to, and then uses those weights to combine the transforms from each bone proportional to the vertex weight.


1

select the mesh, go to deformers and press on armature Preserve volume


1

You can do this as shown below:


1

If you join the head and the torso meshes, and check the weights of Vertex Group Chest2 you can see thats the weighs are different between the separate parts. That is the reason why during the animation the meshes are separating. The solution is to equalize the weights between the meshes, I would suggest using blur brush in weight paint mode.


1

I think it's layer_deform = bm.verts.layers.deform.active assert layer_deform is not None bm.verts.ensure_lookup_table() bmv = bm.verts[0] bmv[layer_deform][vertex_group_index] = weight # or names = tuple(vertex_group.name for vertex_group in obj.vertex_groups) for vertex_group_index, weight in bmv[layer_deform].items(): name = names[...


Only top voted, non community-wiki answers of a minimum length are eligible