7

You need to use the alpha output of the Color ramp as the factor for the mix shader. The color output does not cary the alpha information.


7

You want to connect it like this: You can connect your image as an (unshaded) input into a mix shader, with a Transparent BSDF in the other slot. Use the image's alpha output as a mix factor. Also, for best color accuracy, make sure your view transform is set to "standard" (instead of default "filmic").


4

I've figured it out: I've got to get the Color Ramp as a Fac to the Mix Shader The emission and the transparent BSDF have to be both shaders


2

The root cause was in one of the two UV-mappings... ...all the irrelevant faces somehow ended up collapsed into a singular vertex, which was sitting at a not-completely-transparent pixel at [0;0] coords, hence slightly affecting the paint color in the render output.


2

Material-only Eevee solution: Only a single layer of refracting ojects will be rendered by Eevee, so use refraction (1.0 IOR, 0.0 roughness) instead of transparency and enable screen space refraction. Full shadows, single layer transparency without compositing or geo nodes.


2

Alpha blend requires that meshes get sorted in the right order-- if a deeper face gets drawn after a shallower face, then the deeper face will never get drawn because the depth buffer is already written with a shallower value. That's why alpha blend is so tricky, and gets trickier the more layers of alpha blend that you have. In this case, it is usually the ...


2

You can use the brush strength for this : setting it to a value lower than 1 will output the result you're looking for. Blender's painting system works like a physical painting system, you know those in which you use a paper canvas and gouache-like paints. You don't choose a red gouache with 0.5 opacity, you chose a regular red gouache and the strength and ...


2

Try the brush blending modes Add Alpha and Erase Alpha. The blending mode Mix automatically uses Alpha=1 and removes transparency.


2

This is all you need: Just use the same color ramp twice, use math node to control the emission strength and mix it in mixshader


1

Just plugin the image directly in the material output as you did in your last screenshot. If this doesn't help, please provide blend file. Don't forget before upload to do File-> external data -> pack resources.


1

Your shader is the reason for this: If i mute this "facing fresnel", it stops happening. This is an compositing example, how you could solve it (i lowered the resolution for quicker render):


1

If you absolutely cannot get an SVG, you could create a new texture then displace it on a target cube with a modifier in the Z axis. The only problem with this, is that you must cut away the base and find a way of capping the faces. Update: I have found a bit of a trick with the modifier stack. Using the subdivision, displace, and re-mesh modifiers you ...


1

instead of using PNG just use OPENEXR This works. I read about some limitations about PNG and Blender here in this forum. Note: be aware that if you are working on a Mac, the viewer will not show the EXR correctly. But if you open the exr in the image editor of Blender you will see it correctly. Maybe search for an exr viewer for mac in the internet. ...


1

It looks like the Car Paint nodegroup has issues with noise. I suppose giving more samples would help, but I'm not gonna spend time trying. What you can do instead of using a mesh plane to add your logo, is to simply mix your logo texture into the carpaint shader:


1

Make sure "Screen Space Refraction" is checked in the Settings menu on the Material tab.


1

Found another solution by random using geometry nodes, which doesn't require setting up any extra view layers or doing anything in the compositor. Individual Object Method Add geometry nodes to one of the objects (or you can create a new empty one just for this purpose) Link in all other objects using Object Info node (also switch to Relative so they keep ...


Only top voted, non community-wiki answers of a minimum length are eligible