New answers tagged

0

This is only a partial answer, however, it is giving me some functionality. I assigned the Automatic Constraint to a different button on my Logitech mouse, and with that new button, everything works as it should. If I move it back to the default Middle Mouse Button, the incorrect behavior returns. So, for now, I am sticking with a new assignment.


2

You are probably in Edit mode, you need to switch to Object mode:


2

With your custom transform selected and in Object Mode, turn on "Affect only > Origins" in the Tool sidebar panel. Then, you can go to Object > Transform > Align To Transform Orientation. Done!


2

use this: import bpy ob = bpy.context.scene.objects["Camera"] for frame in range(0,250): bpy.context.scene.frame_set(frame) print (ob.matrix_world[0][3], ob.matrix_world[1][3], ob.matrix_world[2][3])


2

Here's the basic solution how to use it in Blender 3. You can use vector math nodes and/or the distribution node to get more control and expand this method for your needs.


0

Solution: Create Copy of Original Mesh/Armature: Copy and Paste your original Armature and Mesh so we have a new copy in the scene. Apply All Transforms to New Mesh/Armature: Make sure to delete all the animations from your New Copy, zero out the Loc/Rot/Scale for the armature, and now apply All Transforms to all the Meshes as well as the Armature itself. In ...


4

Using drivers: Hover over a transform value (in my example X scale), press right mouse button and choose "copy as new driver". Then over over the destination transform value (in my example X scale of object B), right mouse button, paste driver. Then RMB again > edit driver > change the type from average value to scripted expression and type ...


0

I was able to fix it by restarting Blender, the only thing I hadn't done.


0

You have probably accidentally turned off the gizmos by clicking on the icon arrowed below:


4

Uncheck this tool preference in the properties panel.


1

Press here on options and uncheck all checkboxes if they are checked. and press here: and choose "active element"


2

If the the meshes are identical, apart from the translations, rotations and scale, this can be done by snapping alone, I think the only bit you could improve is using a Custom Orientation? Set Snap to To: 'Vertex' With: 'Active', influencing translation, rotation, and scale. Set Pivot to 3D Cursor. Establish a common vertex, and ShiftS place the 3D cursor ...


0

So I followed @Gordon Brinkmann advice and tried playing around with unit scale. That by itself did nothing at first, no matter how much I scaled up or down, but once I switched the Length measurement to Meters AND applied a 1000x scale to the whole thing it finally worked. An alternative that I also found was to keep things as they were and use the "...


0

All you need to do is to adjust the screw modifier to use the armature as the Axis Object: Now, you can move the entire object by moving the armature in Object mode and you can still animate the deformation of the object by moving the bones in Pose mode.


0

In the Viewport Overlays, enable Curve Edit Mode > Handles > All: Now you can move several handles together:


4

I think it is a bug. What works: bpy.ops.object.empty_add(type='PLAIN_AXES', align='WORLD', location=(1, 0, 0), scale=(2,2,2)) bpy.context.object.scale = (2,2,2)


0

I downloaded a project I did in EasyEDA and saw: The scale is 1 unit = 1 mil (0.01 inches or 0.254 mm), small holes don't seem to have been exported, components are colored but there are no textures. Import the obj file using default settings Make sure the new object is active and click Object->Origin to Geometry Open the Transform panel n and set Scale ...


0

A softbody sim isn't going to update the origin point based on the changing position of the mesh - the object origin "stays" at its original position, even if the sim itself does not (rigid bodies are different since the object itself doesn't deform, so the whole object moves together). I tried running a softbody locally and it had the same issue. ...


1

When you parented your character to the rig so that you could pose it, it created a set of vertex groups, one for each bone. (Either you used 'with automatic weights'; or 'with empty groups' and then weight painting) Joining the clothes to the character does not add the clothes vertices to those vertex groups. The vertex groups are what tell Blender what ...


0

I had the same issue with one of my objects. I believe the issue came up after I joined several meshes each with a mirror modifier. I removed the modifier and reapplied and it appears that the issue has resolved itself.


2

This is because he probably missed one important information... This happens if you do shrink/flatten by default: I don't see him checking one value in tutorial... you have to check Offset Even: After this it should work as intended (also I don't know if you did but use Ctrl+A and select Scale in Object mode before shrink/flatten


1

This is quite "normal" and I experience it with my blends on a friend's 3D printer as well, since different softwares and file formats store and interpret mesh data differently. Let's say Blender stores the value 0.51 for the length and your Blender Scene Properties > Units are set to Unit System "Metric" and for the Unit Scale "1....


2

The scale command takes both an axis and a numerical argument. For your example, SZ.25Enter would scale the selection to 25% of its size only on the Z axis. The axis designation is optional. If you use Shift before the axis letter it will scale on the other two axis. I.E. ShiftZ will scale on X and Y but not Z. If you leave the axis out it scales on all ...


1

If you are using this nodes setup, the texture will follow the scale transformation, as you can see: here rotation:


-1

There is an option in 2.83 solving your issue, but no idea if it's in 2.76. The option is in the same menu that contains Apply Location. I throw empathy your way as it doesn't make sense that 'applying' a new location 'resets' it to the world origin. The option you are looking for is Location to Deltas. This actually applies the location back to null values ...


2

Try to use Alt + S with all faces selected, don't forget to check Offset Even.


1

This is due to the nature of the Lattice modifier and the GP objects: the lattice move vertices, when you scale the lattice you're not scaling the drawings, you're moving their vertices closer to each other but their stroke thickness remains unchanged. A workaround is to add a thickness modifier, select in pose mode an appropriate bone (maybe a Root bone if ...


0

All it is is 2 keyframes and the Z channel set to linear interpolation instead of bezier: Keyframe 1: X: 45 Y: 45 Z: 0 Keyframe 2: X:-135 Y:-135 Z: 360


Top 50 recent answers are included