New answers tagged

0

Check the face orientation of the object. If it is red, go to edit mode, select all, shift + n See if that makes a difference. (Face orientation is in the overlays tab)


3

Okay this took me a bit to figure out. The problem was on the screen_roller object hidden in the viewport, not the Plane.002 object that's overlapping it. You were right the material is fine! It's identical to the materials used on other objects, and even removing it doesn't change anything. The problem is the normals for the screen are facing the wrong way, ...


0

This is a bit silly, but you can create additional scenes and put the scene's camera output in 0001.Video, and then combine that with 0001's sequencer output in 0001.Comp. The latter can then be inserted into your master as one clip that's easy to edit. The render start/ends are a bit difficult to manage between the three of them, but if you overshoot them ...


0

Your scripts are incorrect, you are ignoring scene objects and repeatedly printing data for the active object instead. In both cases you are looping over scene objects with for i in bpy.context.scene.objects: Then you proceed to ignore them all by defining an "active object" with either obj = bpy.context.edit_object or me = bpy.context.object.data ...


0

I stumbled upon the answer myself after asking the question. You have to make sure you're not creating the object inside a collection. Then it works as I expected it to, creating the object only in the new scene and not in the original. I was creating it inside the default collection (the one called "Collection") without realising it. To create an ...


1

Not sure if this is what you're trying to get but can't you put each set of objects as a collection and have the environment on a separate collection then you can just disable rendering of all collections but keep the environment and the set that you want to be rendered .


Top 50 recent answers are included