We changed our privacy policy. Read more.
6

To answer why this happens: Any rotation to that 't' happens around its origin. Since it is offcenter, the rotation looks like this: When the 't' collides with something, and the physics system tells it to have a rotation, this will cause an undue velocity to be given to the mesh in the rigid body sim. It will likely end up clipping into an object and ...


5

turn down collision margin to 0 here: After that they will fall down. You should also reduce friction to get a realistic result.


5

As I have said in the comment, make your chain by links, select them all and join them together. Go to Physics and give this object Rigid body physics. Use these settings: just make it active and change the convex hull to mesh... you can tweak mass later to give it better results... After that go to edit mode, select all vertices, use RMB and select ...


3

When you separated the text into separate objects you should have set the origin of each new object to the that object's geometry. Also you would have benefitted from applying the rotation of the text. You may want to adjust the mass settings of each letter for more realistic behavior.


3

That's not hard. You need a Rigid Body Constraint... well, a lot of them. The Fragmentation Create the Quick Effects > Cell Fracture. (Requires the enabled Cell Fracture add-on that comes with Blender) Move the created fracture objects into their own new collection (M) Make them rigid bodies with the menu entry Object > Rigid Body > Add Active ...


2

Not drones but Suzannes, only 8 of them, only moving in 2D, very unimaginative formation, but the key principles are here. Run the script, move mouse over 3D viewport, press Space. import bpy, copy from bpy import context as C, data as D from mathutils import Vector sim_start_frame = 1 # when to start the simulation sim_end_frame = 2000 # save CPU ...


1

Changing Source type to Base in the cup fixes the issue


1

Besides the problems mentioned in the comments, there is something wrong with the spiral. The softbody simulation is very slow for some reason. The recreation of the softbody physics didn't help so I recreated the curve itself. (created a spiral with the Extra Curves add-on, set Bevel > Depth in the settings, rotated, and scaled it a bit). This fixed it. ...


1

I'm not sure this is exactly what you want but maybe it will help, I've deleted Armature.001, deleted all the keyframes of the links, made the first and last link Type > Passive instead of Active, put the origins at geometry and added edge loops:


1

This has been posted in response to @John MC 's request in the comments above. It also addresses the problem outlined in CyberHavenProgramming's question... It's a simple example of influencing cell fractured segments (and particles too) to travel in a desired direction and velocity. (Blend file is below) A plane is simply placed vertically, like a wall ...


1

You could create your pill, give it Rigid Body physics (Active), disable any gravity in the Scene Properties panel, enable the object's rigid body Animated option for several frames, animate a short rotation then disable Animated and let the physic play so that it continues its rotation, create a Force Field (Force type), here I gave it a force of -200. Then ...


1

Thanks to @MartyFouts for helping figure out a solution. If I change one of the simulation settings, and then re-bake, then it overrides the old bake and makes a new one. But it doesn't update the simulation if I just move the rigid body objects around in the scene. So I just have to change a setting, like the simulation speed, and then re-bake it. Then once ...


Only top voted, non community-wiki answers of a minimum length are eligible