A message from our CEO about the future of Stack Overflow and Stack Exchange. Read now.

New answers tagged

1

I assume you have set the plane to Rigid Body in the Physics Tab. In the Physics Tab, change its Type from Active to Passive. Voila! The plane will not fall. Add Collision to the sphere to stop it falling through the plane. In 2.8x, this will happen without having to add Collision.


2

Change the ground plane's Rigid Body Type to Passive


1

I find if I turn these settings up and turn sensitivity,Margin to 0 I get good results in similar simulations.


0

Why not try collision sectors? with a simpler armature like a character you can place collision bounds automatically to each limb. (manually assuming the size of the collision bound you need). and use integrals or for loops to get measures between Bone.pose_head & Bone.pose_tail for higher quality collisions to your charactar mesh. I already attempted ...


1

There may be methods that doesn't require aniamtion nodes, I will test that later. but here is what I thought at the most beginning and has been proven to be working: Theory: using locations of particles as a guide for rigid body objects to set in their places. The intersection will be prevented by rigid body dynamics. Add a particle system to a mesh. (...


0

The issue I was running into was that I needed to use a heat attribute node. Once I added that with the flame attribute, it worked. (I also didn't separate the nodes anymore) Thank you everyone who helped.


0

you can change the outer setting in the physics tab. this changes the size of the collision box and will stop the object from sticking


4

Rigid bodies There is no mention of the underlying physics engine in the manual for the current version v2.81. However, up until version 2.79, Blender used to have also a Game Engine, which shared the same physics with the general Rigid Body World used for animation. Its manual gave more away in terms of the underlying engine: Blender includes advanced ...


0

The order of the modifiers was the cause of jagged shape! Changed the subdivision modifier after the cloth simulation.


1

I found the solution: When the spoon is selected as Fluid/Control there are two parameters which must be changed: Attraction strength: with positive value attracts the fluid and with negative repels it. Velocity strenght: the influence of the spoon's velocity with the fluid. Just try configurations until get what you like.


1

The solution was quite simple. Didn't understand the nature of the baking process and how it worked when the physics object (plus forcefield) was a child of an moving parent (the camera). Being a bit unexperienced in the physics field I did'nt understand the obvious necessity baking the flag / running the entire animation. After executing this the flag ...


0

This is most likely because you did not change the location of the fluid bake. Set the fluid bake location to an empty file on your computer separate from the other bake, and try again.


0

You can actually animate the object, and the fluid should stay with the object. You should increase the strength of the control factor while it moves to make sure the fluid doesn't slip away.


0

I have had a similar problem. My fix was to make the pipe after I simulated the fluid. This works pretty realistically. Hope this works for you!


3

Speaking to trampoline effect (simple one) ... falling object with two keyframes (start / end Z position) with Dynamic Effect Elastic (T) set in Graph Editor with first keyframe selected "trampoline" worked better for me with Soft Body sim (Mass zero, Goal > Strength 1) To protect object from penetration try for object Collision > Outer Thickness increase ...


0

It was a dumb mistake, it turns out. I had rendered it without baking it. And when I baked it and then rendered it, it was rendering the image sequence I had previously rendered, so no changes were being displayed. It has been fixed now.


2

Your resolution is too low. Try setting it to at least 150 but preferably more. Yes, this will mean longer simulation times, but that's the catch with all simulations! The resolution determines the size of the grid elements used by the simulation engine: your elements are so big (you can see the big blocks in your screenshots) that the walls are too thin ...


0

I'm no expert, but I'll see if I can help quickly. Is the outer mesh with normals pointed in the right idea? You might need to give it some thickness somehow, perhaps by using a solidify modifier on its surfaces. Or maybe the whole thing is trying to behave as a solid (even though you say the normals face inwards) ...if the tutorial got you here, then ...


-1

I am experiencing the same problem. I did find a tutorial with a workaround implementing a third particle set. Unfortunately I have to recreate the workaround each time I change the keyed animation transform. I hope you find this link helpful. Blender Beyond Basics #4: Fun with Transformations - Blender Tutorial


4

I red the question, but since it's a bit confusing for me (so many steps) I sticked with title - to solve passing objects, with a file you provided. Start position of leaves comes from particles behaviour (they collides only in circular shape. Enabling Rigid Body to these leaves results in move ("explodes)" them down. In a Rigid Body World, there is ...


0

While all the answers point out some reasonable things, i believe that it's most likely that the Rigid Body Collision Source" needs to be set to "Final" so all modifiers are included in the calculation, as OP mentioned all but the marble have modifiers to them. Also mentioned as try to from @Jackdaw, the Rigid Body World settings, especially the "Steps Per ...


0

If the passive rigid body is animated then don't forget to turn on Animated in the passive rigid body settings or else the active bodies will not collide.


0

Whenever I had this problem in the past with smoke, it was because you have to manually click the bake button in the cache section and cannot just play the sequencer for a bake. That could be the problem.


1

Okay, so I fixed it by myself, just by deleting previous object 'sphere' and creating new one. Here are the settings which work good: So I don't know why it wasn't working with previous object, but the solution is to replace it with a new one :)


Top 50 recent answers are included