New answers tagged

2

For the particles: Start with a sphere move one vertex far away using proportional editing so that neighbor vertices are also stretched proportionally to create the cloud of particles, use 2 array modifiers to create a matrix, apply the modifiers and separate by loose parts use proportional editing with Random and smooth fall off in order to arrange the ...


0

The particle system is based on faces of the boolean intersection between a very narrow cube and the mesh text. The problem occurs when that boolean operation is between letters, creating an empty mesh. The particle system still needs to produce particles at the rate declared (10000 over a few dozen frames) and thus default to producing those particles ...


0

Duplicate your main volume in place Remove the particle system from the main volume Scale down the duplicate so that the particles fit into the main volume make sure to turn Show Emitter off in the Particle Settings panel


0

i don't know if you already figured this out, but when the hair is going all over the place, if you want the hair to move together like a head of hair or like a main, you need to set the voxel size high enough, 1.0 is a good start, and then set the hair target hair density to 0.5, and target strength to something like 0.01. Goal strength i set to 0.3 for ...


0

As far as I know, you can only do it using Cycles. So, once you've changed your render engine, head over to the Particle Properties tab and tweak the values under the Hair Shape section until you get satisfied with the result. The first three inputs are pretty intuitive, just mess with them; the fourth one is simply a global scaling factor.


0

i don't know if you already figured this out, but when the hair is going all over the place, if you want the hair to move together like a head of hair or like a main, you need to set the voxel size high enough, 1.0 is a good start, and then set the hair target hair density to 0.5, and target strength to something like 0.01. Goal strength i set to 0.3 for ...


2

Maybe you can use some sort of Musgrave or Voronoi texture to form the base clouds, then mix up texture coordinates with a Noise texture to distort them into something more irregular. Squash the textures in Z, or stretch in XY to get the elongated look.


1

You need to make sure that the particle system is placed last in the modifier stack (the bottom most one) : And also check "Use modifier stack" in the source panel of the particle settings :


0

If you have a texture image than you probably forgot to Choose it for your UV.Go to UV than select new file (locate that image) Now turn the edit mode and go back to UV tab and make the highlighted cubes fit the whole image. If you already have an image selected than it must be because you haven't done the shading part correctly.


2

You need to register the class to use it. Also bl_context = "PARTICLES" should be replaced by bl_context = "particle" Here's the complete script import bpy class CudaParticlePanel(bpy.types.Panel): bl_idname = "CudaParticle_Panel" bl_label = "CudaParticle" bl_category = "SYSTEM" bl_space_type = 'PROPERTIES' bl_region_type = 'WINDOW' ...


0

You need to select the mesh used as particles/hairs and go into edit mode. Rotate and move the object (in edit mode) till the emitter emits the mesh correctly.


2

Look at https://blender.stackexchange.com/a/172271/35559 for some updates or possible fix. Meanwhile, not really sure what's happening but even on a simple non cyclic curve, you can see the beltlink flipping orientation as it moves along the Y axis as soon as it reaches a curve control point (which is aligned and "flat"). May be a bug, something linked with ...


0

Use Emitter instead of Hair Check Rotation/Normal to align the particles to the Face normals Disable Physics Check Unborn and Dead to make sure the particles don't appear/disappear


0

It looks like your particles are actually emitting light. In order for this to happen, they either have an emission shader, or a principled shader in which the Emission value is not set to black. If the particles using an emission shader, simply change it to a principled shader and that should fix the problem. If they are using a principled shader, simply ...


1

Particle System Settings: Check "Advanced" Check "Rotation" Orientation Axis: Normal-Tangent Children Simple -> Interpolated Render Under "Object" check "Object Rotation" Hair strand object: Viewport Header Tool Settings Options Under "Affect Only" check "Origins" Move the origin to the root of the hair strand object Unset "Affect Only Origins" ...


0

The particle options in Blender are rather limited at the time (they promised to change that in 2015...) so the only solution I can think of is Animation Nodes or Python, delete the particles depending on their start direction.


0

Of Blender 2.78 to Blender 2.82 there were several changes. Now the code that yes work: import bpy depg = bpy.context.evaluated_depsgraph_get() object= bpy.context.scene.objects['Plane'] particles = object.evaluated_get(depg).particle_systems[0].particles bpy.ops.text.new() for p in particles: bpy.data.texts[-1].write("<particle x='"+str(p....


2

(this tricked also me) you need to add at leat two materials to the emitter mesh and then under the emitter setting you'll find both the materials (just select the one for the hairs)


0

I probably need some screenshots, but I'll give it a shot: Blender hair physics cannot get the same physical behaviour as their visualized object. Not that the object gets inserted in the "Render" tab, not the physics tab. Hair have their own strand based physics, which are limited. Unfortunately (to my knowledge and frustration) you cannot even make the ...


0

You can do this with Animall (Addon, has lots of presets), but I always found it a bit wonky and it's not really migrated to 2.8 yet. With a little more effort you can use Animation Nodes for that, in the end you have way more control over the behaviour of your path. Here's a screenshot of my Nodetree, note that the dotted line is just the visualized motion ...


2

Final hair particle size is the result of multiplying hair length with particle object scale. Default hair length is $4$ Blender Units, so to get an object of identical size to the original you have to multiply it by $1/4$, hence $0.25 \times 4 = 1$ If you plan on rendering particles as objects and need easy to set up scales then change hair length to $1$.


0

Seems like the hair is inside the mesh. Try brushing the hair in Wireframe mode so that you'll have an idea where you need to brush. Hit TAB and goto Particle Edit. Select "Puff" and click on the hair that is inside which'll make the hair stand up straight for every click of mouse (or) use "Comb" to drag the hair the way you want.


0

Your hairs are growing but they are apparently combed down inside the mesh. You can use the puff-brush in the particle edit tools to get them back out. Seems like you are growing your hair with a global down direction, I'd rather recommend growing them normally and then grooming your model with the particle edit toolset.


0

I found the answer myself: In my case The Particle Info Node attaches to a material setup for the instanced mesh object used in one of the Particle systems. Therefore the Particle Info Node can only be relevant for that particular particle system.


0

edit mode (the single object that you use as RENDER object of the emitter), move and rotate till the emissions are ok.


0

The emitted particles (sprinkles) are attached to the emitter (donut) in their origin points. If the origin point is far from the object, the emitted particle will be far from its emitter. Check the origin point of the emitted object, Perhaps it's not adjusted to geometry. Select the emitted object (the sprinkle) > Right click > Set origin > Origin to ...


1

Particle Properties -> Click on Liquid -> Viewport Display -> Size 1mm or something smaller As seen on: https://blenderartists.org/t/is-there-such-a-thing-as-too-small-of-a-scale-for-mantaflow-flip-fluids-particles-too-big/1208348


1

From a Youtube comment: Johnathan Burkhardt 1 day ago I had the same problem! If you go to Particles > Render > Collection there is a checkbox for "Pick Random." I clicked that and it fixed the problem! Sorry guys, I knew it was a noob problem.


0

Can you share the file? (https://blend-exchange.giantcowfilms.com/) why are you in frame 134? You can create another emitter only for the "spheres", so it probably fixes your "group" problem.


4

I'm assuming you sent the real texture. Your texture is a png in a particular case: it is an index image. The index image has a short Color Table, only 256 colors. You have a pink gradient using a too limited number of colors. I'm sending an image showing the problem when I changed the Color Table. Note the stripes are only affecting the pink colors. To ...


0

Under Particle Settings -> Source enable the check mark Use Modifier Stack


0

try this setting in shader: the "particle info node > index" in shader helps you to control a single particle (use a math operation to filter which particles to hide). Please note: animate the value inside the MATH -> GREATER THAN (from 0 to the number of hairs) you need alpha = 100% to hide the objects


0

some fixes: goto the raindrop object properties > Instancing > switch to None go to the emitter, clear the bake cache and recalculate the bake just to check that drops now are in the render: go to shader and make the drop more visible (for example make the shader less transparent) result:


2

Behaviour is wierd and I had no luck with proper setup. This is not an answer, just some notes to OP – Cubes Physics Properties Friction 0 Friction 1 Friction 1, Stickiness 10 Result is affected also by speed animation as well, but I never get them on place even with slowmo. It looks like tablecloth effect :) Molecular Substeps set zero keeps particles ...


3

I maybe have solved it using particles in the lower cubes, and particle linking on collision while simulating everything with molecular. Check the provided blend for more details. (there is a text file inside, with a few small hints) Short version: Cube particles are linked on birth, and also perform linking on collision with nearby plane particles. Note, ...


1

Daily Blender Secrets - Fix Overlapping Particles with Blue Noise Particles add-on Daily Blender Secrets - Fix Overlapping Particles Daily Blender Secrets - Non-Overlapping Particles (Method 3) First video: Download the zip file In Blender, go to Edit; Preferences; Addons; then select install from file and pick the zip. Tick the checkbox to enable the ...


0

I just dealt with this. Check your Timing panel and make sure the ending is set to 1.0 Hope this helps. It did it for me.


0

You probably solved this by now but in case anyone is wondering - I had the same issue with emitting metaballs showing up fine in the viewport but not rendering. In my case the emitter object had rigid body physics enabled. Once I disabled that the problem was solved and metaballs rendered fine


4

I managed to do that also. You don't even need the add-on. Run the particle simulation for a short while (space) Convert it to objects Go to Object > Rigid Body > Add Active Shift-select one ball Go to the Rigid Body tab and put shape to Sphere Right-click it and 'Copy to Selected' to put it to all selected spheres Continue playing (space), let the balls ...


3

I came across ParticleInstance modifier. I'm not sure if this is the best way to do it but it seems to work. In the particle system settings, render as object and use Empty: Add a ParticleInstance modifier to the actual object and place it before the Displace modifier. To use the size randomness, enable the Size option: Edit. Actually the 'Render As' ...


0

Your 2nd and 3rd hair particles are controlled by vertex groups "Group.001" and "Group.002" which don't have any weight applied. Just weight paint them where you want the grass to spread. Also you should invert the normals of the plane (now they are facing downwards, select all then Shift N in edit mode, choose "inside" option), and put the origin of the ...


Top 50 recent answers are included