Hot answers tagged

124

Ensure GPU Support Currently cycles supports CUDA (Nvidia) devices and has experimental support for OpenCL devices as of 2.75 (added in B7f447). If you are using an AMD/ATI graphics card, see the OpenCL section below. If you are running an older NVIDIA card, ie the Geforce series, support is extremely limited and these are not officially supported, see How ...


9

As it's still quite experimental and there are quite a few features still missing, it's only enabled for AMD gpus by default. It's possible to "force" it to work on other opencl devices by setting the environment variable CYCLES_OPENCL_SPLIT_KERNEL_TEST=1 Linux On Linux, run the following in a terminal: CYCLES_OPENCL_SPLIT_KERNEL_TEST=1 blender ...


6

Also note that you need to change 2 settings to enable GPU rendering. The obvious one is in the User Preferences, System. You also need to set it for the blender file (scene) by clicking on the camera icon (on the left) in the Properties window and under the Render section is a setting for Device.


5

Not currently supported, I'm afraid. You can see the list of supported features over at the Blender manual As of Blender 2.78a, October 2016: Feature CPU CUDA (NVIDIA GPU) OpenCL (AMD GPU) Basic Shading ✔ ✔ ✔ Transparent Shadows ✔ ✔ ...


5

AHA! So it turns out that I needed the ocl-icd-opencl-dev package installed. Once I installed that package... \o/


4

TL;DR There is no official limit of GPU's on cycles but setups bigger than 10 GPU's were never tested so far. After not so extensive research I've contacted one of the blender developers. According to him in this thread: Blender dev forum there is no official limit on cycles. However blender 2.80 is still under development and such a huge setup was never ...


4

This is a list of AMD GPUs known running together with OpenCL and Blender Cycles. It is composed by either personal experience or from sources on the web: ╔═════════════════════╦═════════╦════════════╦════════════╦════════════╦════════╗ ║ GPU ║ OS ║ OS version ║ Blender v. ║ Driver ║ Source ║ ╠═════════════════════╬═════════╬════════...


4

When rendering an image using the GPU, the data somehow needs to be loaded from your disk, preprocessed, pushed into RAM, from there into VRAM where the GPU finally starts doing its job. Everything up until the point where the data enters VRAM is done by the CPU. If your GPU is working at 100% there is simply no need to push more data into this pipeline, ...


2

I have found solution to my problem. To enable openCl on Linux Mint 17.1 with ATI radeon video card just install ocl-icd-libopencl1 package for 64 bit system, or ocl-icd-libopencl1:i386 for 32 bit system. No need to run Blender as root or set up environment variable.


2

Not all ATI cards are supported. The list of supported cards per Blender Development can be found here. While this is not the entire list of cards that have shown to work, I believe they are the GPUs that have been tested "working" by development. From what I've observed from other ATI users, any card that does not have OpenCL 1.2 or 2.0 support, does not ...


2

I know this isn't the answer you're looking for (it's not one I'm happy with either), but, at the moment—even two months after you first asked… You either need a different video card or a different OS. OpenCL support is currently broken in the official AMD drivers for the RX 550 specifically {1}. This is still true as of the 17.30-465504 AMDGPU-PRO drivers ...


2

I just made the render use 100% of my resolution [...]. This is an important change, since a higher rendering resolution requires more memory. The error you are getting tells you that Blender could not get enough memory from your graphics card. If you do not want to use a lower resolution, simplify your scene by using lower resolution textures for far-away ...


2

As of march 2017 GCN 1.0 is no longer supported for gpu rendering. Because the R5 M330 is using that architecture you won't be able to use it anymore in blender. Sources: https://wiki.blender.org/index.php/Dev:Source/Render/Cycles/OpenCL#Current_issues_and_limitations https://en.wikipedia.org/wiki/AMD_Radeon_RX_300_series#Mobile_products


2

Your computer already do this automatically. VRAM is only storing very frequently-used resources that need to be accessed in a very short amount of time. If/when the VRAM is used up, most computers will attempt to transfer some of the less important information your your RAM. DirectX, AGP and PCI-Express cards do this automatically. You could manually ...


2

That is because Cycles in Blender 2.8x only uses OpenCL for AMD GPUs. For Nvidia GPUs you have to select either CUDA or OptiX (only for RTX cards). This is documented in Blender's manual. Nvidia CUDA and OptiX are supported for GPU rendering with Nvidia graphics cards. AMD OpenCL is supported for GPU rendering with AMD graphics cards.


1

You might need to install the proprietary AMDGPU-PRO drivers, or at least the OpenCL part of it. The quick fix is to install opencl-amd from AUR: git clone https://aur.archlinux.org/opencl-amd.git cd opencl-amd makepkg -s sudo pacman -U opencl-amd-*-x86_64.pkg.tar.xz (You might have to downgrade libdrm for opencl-amd to work, see here.) Note that Arch ...


1

OK, looks like todays (07/07/2018) Blender 2.79 is baking using GPU + CPU without crashing. Plus I've unchecked the square samples and now it baked the same file with same node setup in 40min instead of 44 hours. very nice!


1

For reasons unknown to me, installing Radeon RenderPro for Blender has fixed the problem! https://pro.radeon.com/en/software/prorender/blender/


1

Looks like you have multiple scenes in your file. To cycle through them and set them all use: for scene in bpy.data.scenes: scene.cycles.device = 'GPU' bpy.context refers to the to the area of blender which is currently being accessed by the user, not the script loop. If you don't have the file open, I would avoid using bpy.context calls and instead ...


1

Your GPU is GCN 1st gen. That's why it's not supported. Cegaton pointed out in a comment Can't use Radeon GPU to render in cycles (R9 270) Which is where I figured that out from this list here https://en.wikipedia.org/wiki/List_of_AMD_graphics_processing_units EDIT: Originally I claimed and cited that Nvidia's Cuda core programming has higher support ...


1

Currenty, there is no support for AMD and nVidia GPUs to be used simultaneusly in Cycles (update is to arrive very soon from what I understand). One option is to use Radeon Pro Render engine developed by AMD. https://pro.radeon.com/en/software/prorender/


1

Just go to http://support.amd.com and download the latest driver. You cant do much wrong. Other then that, there's no special setup needed. Also: As you can see here, the OpenCL/AMD support in Blender got a huge leap with 2.79.


1

I had a similar issue, I'd set GPU render, it would say "loading render kernel (this may take a few minutes) and after a few seconds, crash to desktop with no error. I'm not an expert so this may be off but my understanding of how blender works is, if you want to render on GPU, it has to compile that kernel and it saves the info in a folder, in windows ...


1

The solution is the update the drivers. Version 15.07 works fine with 2.75a.


1

I recently got the MacBookPro 2017 Radeon Pro 555 2 GB + Intel HD Graphics 630 1536 MB. Having both GPU on apparently causing Cycles not to render. Just turning on Radeon Pro 555 and turning off Intel HD Graphics and the Cycles render works.


1

You should be able to configure the compute device on each machine, submit the render job, and have it "just work". In fact, this is the main reason why the compute device settings are in user preferences instead of scene settings: to allow them to be set per-machine, rather than per-scene. Two things to be mindful of: The scene needs to be saved with "GPU ...


1

This is a bug in 2.78 which has since been fixed in master (bug T49846, fixed in this commit). Luckily you don't have to wait, you can fix this bug yourself. Edit the following file: C:\Program Files\Blender Foundation\Blender\2.78\scripts\addons\cycles\kernel\kernel_projection.h On line 238: float altitude = fabsf(safe_asinf(D->z)); should read: ...


1

The HD6670, and other older Terascale-based cards from ATI/AMD, are not supported for GPU rendering with Cycles. We only support graphics cards with GCN architecture (i.e. most HD 7xxx and above).


1

check the progressive refine box in render panel.


1

On Ubuntu open the Terminal and do: sudo apt-get install ocl-icd-opencl-dev then: CYCLES_OPENCL_SPLIT_KERNEL_TEST=1 blender


Only top voted, non community-wiki answers of a minimum length are eligible