4

In the material named Material.003 , you have a Principled BSDF node that has a Clearcoat value set to 1 and Clearcoat Roughness set to 0.03. This emulates a reflective layer on top of the normal Roughness value.


4

Have a look into: Control Cycles/Eevee material nodes and material properties using python? The emission node is created by default. All you really have to do is adding the blackbody node, set the properties and connect it using NodeLinks.new(): https://docs.blender.org/api/current/bpy.types.NodeTree.html?highlight=links#bpy.types.NodeTree.links import bpy ...


4

You can't see the light object because you've disabled the Show Overlay option (see image below). Also, if you render, you won't see any light, only the light effect and its reflection on objects, if you want to see a kind of light source in your render you need to create an object that will look like a light source, for example a sphere with emission to ...


3

Inside the shader editor for the image, replace the Principled shader with an emission shader. Your image looks dark because of the shadows on it, and giving it an Emission shader will remove the shadows.


3

Make sure that you have enabled the Display Overlays button (double sphere icon button on the top right), or that you haven't disabled the lights in the Object Types Visibility panel (also top right, eye icon button):


3

Check this add-on Sequence Bakery from @p2or ... it seems to do what you are asking for ... tested on 2.93 I expect you know how to bake ... just be sure your newly created image is saved before you run operator. Sequence will be saved into that directory as well. Baked Image sequence of shadow pass (without indirect and other passes :) Previewed in Solid ...


2

First of all, I'd like to mention that volumetric scattering does work with emission shaders, not just lamps. Although if you can use lamps, use them instead as they are easier to compute, therefore shorter render times. The simple answer is to either increase the volumetric density and/or increase the brightness of your lights. These are objects with ...


1

Maybe replace the principled BSDF to emission shader and you can increase the strength of the emission


1

just tap that icon to see them again.


1

I would disable the render denoiser, add a denoiser pass, and use the compositing denoiser. It seems to do a better job. Disable the render denoiser in Render Properties of the properties editor: Enable the Denoiser Data pass in the View Layer Properties of the properties editor: Here's a staring point for a denoiser pass in the Compositor:


1

128 samples on this setup is spreading it quite thin. The new default sample count is high for a reason: more samples means less noise, and with a better Cycles engine, shorter times for samples means we can afford more of them. Set the count to at least 512.


1

It looks like one of the objects was originally smooth shaded while the other was not. Select the joined object in object mode, Right Click and select Shade Smooth from the menu. Then go to the Properties editor → Object Data Properties and open the Normals panel and select Auto Smooth.


1

You could use a driver for the power of the light: Select your light, right click in the Power field and select "Add new driver". Then open a driver editor view and edit your driver type (the button to the left of "var") to be distance, and specify your lamp and the proximity target. Here, I've set the brightness of the lamp to 1000 ...


1

You have an error in your Image Texture: You should change "Non-Color" to "sRGB".


1

Not as part of the glTF model itself, no. There have been a few proposals for IBL and environment storage in glTF (one recent proposal is in PR #1956), but none of these are ratified by Khronos or included with the Blender glTF exporter as of yet. In general many applications find it more convenient to keep the model separate from the environment, for ...


1

Check your shader graph. In the Image Texture node for Normals, check if your color expression is set to Non-Color. Changing it from sRGB to Non-Color fixed the issue for me.


Only top voted, non community-wiki answers of a minimum length are eligible