New answers tagged

0

I ended up making a new Blender project and appending the cup, donut, sprinkles in their respective collections into the new blender project and lighting appears ok now! :D Never found out what went wrong in my old file, there is some setting hidden in there that made shadows iffy.


1

I made a little progress, turning off Filter Glossy to 0 under Caustics seem to have worked. I played around with the other Light Paths after and this is what I got so far: and lamp setting: I will continue the tutorial now, maybe he will mention his Light paths settings at some point.


1

If you add a Value Node to your graph, you can type #frame in the value field which will make the value correspond with the current frame as the frame changes. You could combine this with math nodes to set the timing and the direction (toward beginning or toward end) of the fade that you want. This example fades the background from bright white (At frame 0) ...


0

in eevee you can use this setup: -> important is the blend and shadow mode of the material. if you then toggle to cycles, it works as well: and here is the blend file:


2

On the top right corner there is a play button: This enables/disables viewport rendering, clicking it should start previewing your viewport render on cycles


1

just use this setup for your object. (i assume your are using cycles) blue is your object color, on the orange bsdf you can change the alpha to change the shadow darkness.


3

There are several effects here. For the light rings effect, you can create a curve circle, give it depth in the Properties panel > Object Data > Geometry > Bevel, then give it a material with this node setup: Texture Coordinate (Object output) > Mapping (stretched on the correct axis) > Noise Texture (play with the Scale value) > ColorRamp ...


2

You need to tweak the Subsurface Radius values. They will determine the RGB coloration. As the manual says, this value corresponds to the average length the light travels between each bounce. The longer the path length is, the further the light is allowed to scatter. This is the main source of a material’s perceived « scatter color. » A material like skin ...


1

This issue must have occurred due to shade smooth. This issue is quite common. All you have to do is go into object properties -> Normals -> AutoSmooth


0

Inspired by Allen's answer I too went into the SSS rabbit hole... :) You can actually get close with reasonable amounts of scattering. Basic SSS principles apply Subsurface Color - visible in shadows SS Radius (Scatter color) - visible on edges and backlit parts Used Random Walk method for SSS (slower but more precise) Yeah I slapped a mickey mouse face ...


2

It strikes me as a two point lighting setup, where both lights are slightly behind the model giving the front a heavy shadow. This is a top-down view of my sample scene. I couldn't get anywhere close with a material until I started messing around with some very strange SSS values. My world lighting doesn't match the reference, and it may have been taken ...


2

You can: Select the light, press Ctrl0, and in the N panel > View > View Lock > enable Camera to View: You can also select the light in the Properties panel > Scene > Camera:


0

This is the result and the node setup: Important: set the shader property to this: (alpha blend) THe box needs to have transparency, so that the light can "come" out. This does the first mix shader. The second one mixes then the material of the cube with your plastic look (i just took a diffuse shader to simplify it) a even simpler way would be ...


0

You should increase the radius of your point light until it's the size of your star (which will produce more realistic shadows) and then increase the shadow's clip start to make sure the star's surface doesn't occlude any light, but not too much so that other objects can cast shadows:


2

Mix with transparency on the basis of light paths/is shadow ray, and you can make the wall invisible to the camera, but visible to your lights:


0

No light bounce, it's the way Eevee works by default, in order to calculate faster. If you want to reintroduce light bounces, create a Light Probe > Irrandiance Volume, scale it, stretch it so that it contains all the area you want to be taken into account, in the Object Data panel give it a better Resolution if necessary, then in the Properties panel >...


0

If I understand you correctly, you want the background plane to be unshaded. You could use a material that does not use a shader node, by creating a new material, removing the Principled BSDF node, then connecting a node like RGB or a texture node to the Surface output. Note, this would make it so that it would not interact with any light source. If you want ...


1

This is the original browser window with the Blender render window on-top showing the default cube rendered over original page, which was clipped as an image. And this is the node setup that created it.


4

Recommended way is to use low level API calls. Create a new light data block using BlendDataLights.new(), create a new object using ObjectData.new(), link the light data block and add the object to the collection in context using CollectionObjects.link(object): import bpy # Create light datablock light_data = bpy.data.lights.new(name="my-light-data&...


2

The answer is very simple - I had set up "Workbench" to do a test render last night on the animation - and you can't affect the lights in workbench mode. Who knew? So if this turns up for anyone - now we know.


1

There is a setting under Screen Space Reflections on the Render Settings tab called Edge Fading. Just turn that to zero.


Top 50 recent answers are included