Hot answers tagged

16

It looks like the Khronos Group also has an official exporter for version 2.0: https://github.com/KhronosGroup/glTF-Blender-Exporter


12

GLTF Importer for Blender - now in progress: https://github.com/ksons/gltf-blender-importer


10

There is an exporter available here: https://github.com/Kupoman/blendergltf While its work-in-progress, its already usable for exporting textured meshes.


10

Blender 2.80 (still in Beta as I write this) now ships with glTF-Blender-IO pre-installed. This is a refactoring of the original Khronos glTF exporter, combined with @Julien's importer. Both of the original projects should be considered obsolete in favor of the newer, combined glTF-Blender-IO project. The Blender Manual includes documentation on ways to ...


6

In short, there's an exporter for the GLTF format from Blender (which I assume you have installed), but as of this moment, no one has written an importer add-on or extended the export add-on to support importing as well. This is why you can export, but have no options for importing.


5

A more advanced glTF importer for Blender : https://github.com/julienduroure/gltf2-blender-importer


5

Blender 2.80 now ships with glTF-Blender-IO pre-installed. This is a combination of the original Khronos glTF exporter with Julien Duroure's glTF importer. The Blender Manual has documentation on importing and exporting glTF, including a section on how to get physically-based (PBR) materials to glTF.


4

There is also seems to be alpha version of importer: https://github.com/ksons/gltf-blender-importer


3

UPDATE: For Blender 2.80, see the Blender Manual 2.80 glTF/GLB documentation. These instructions are for Blender 2.79x with the Khronos Blender Exporter: https://github.com/KhronosGroup/glTF-Blender-Exporter In addition to installing this plugin, you will also need a copy of the glTF2_Principled.blend file that ships with the plugin, for a custom node ...


3

For Blender 2.79(x), use the Khronos Blender Exporter: https://github.com/KhronosGroup/glTF-Blender-Exporter To install it, copy the scripts/addons/io_scene_gltf2 folder to your blender-2.79*/2.79/scripts/addons/io_scene_gltf2 folder. Then, re-launch Blender, go into User Preferences -> Addons, search for glTF, and enable the export plugin there. Please ...


2

The glTF format uses normal maps, not bump maps1. If you can bake your bump map into a normal map it should export correctly and appear the same. Sketchfab also allows you to download your model as glTF, so it may be worth trying that. 1The term "bump map" can mean different things, so I'm generalizing here... For a more precise answer I might need to see ...


2

If your goal is a smooth appearance, you can use smooth normals to give the effect of a smooth surface with fewer loopcuts. If you are sure you need the loopcuts, your options are: Disable export of normals, tangents, UVs, and any other per-vertex data you aren't using in the exporter settings. The glTF format supports compression, but you'll have to apply ...


2

Thank you gandalf3. My mistake was the path. I tried ~/.blender folder when in fact I had to copy the addon under ~/.config/blender/.. Works now, thank you again!


2

You're doing good to use the PBR node inside Blendere but include the textures (make them internal), then save the .blend file. THEN export to .GLB, it should work. Relative path issues mess the drag-drop on Facebook post.


2

You have to consider that materials in cycles get translated. As the glTF 2.0 Exporter documentation says: Blender supports two material settings: One for Blender Render and one for Cycles Render. Fortunately, the glTF 2.0 Materials can be simulated using the Cycles Render by implementing a custom node tree You can't just write materials in cycles and ...


2

They're different shading models; it may not be possible to exactly match one with the other and vice versa. If you're creating a model for export into some 3D engine, you should try importing both and verify that it looks correct there, as ultimately the engine will determine how it looks. In the future the glTF Blender Exporter will work with the ...


2

An ORM texture stores each map in a channel : Occlusion in Red channel, Roughness in Green channel, Metalness in Blue channel. You need to use a SeparateRGB node to split the texture into separate channels. Then, simply connect each channel to the corresponding input.


2

I'm assuming you're asking about Blender, since you posted this on the Blender Stack Exchange. Blender offers a "Format" chooser at the top of the export options for glTF, with three options: glTF Separate (.gltf + .bin + textures) glTF Embedded (.gltf) glTF Binary (.glb) The last one, *.glb, is the default. This is the most compact and shareable form of ...


2

The imported image is using the "Diffuse BSDF" shader, but glTF has a PBR material system that is based on the "Principled BSDF" shader. Luckily, you can just swap one for the other to get this working. Use the "Shading" tab at the top of Blender 2.80 to get to this area, and replace "Diffuse BSDF" with "Principled BSDF": Additionally, if your image has ...


2

glTF is a GPU-ready format that only supports meshes, not other types of geometry directly. Your SVG has imported as curves, not meshes. To make it compatible with glTF, look for the convert option in the Object menu of the 3D view: Object -> Convert To... -> Mesh from Curve/Meta/Surf/Text


1

glTF is a GPU-ready format that only supports meshes, not other types of geometry directly. To make the text compatible with glTF, look for the convert option in the Object menu of the 3D view: Object -> Convert To... -> Mesh from Curve/Meta/Surf/Text If needed, make a copy of the text beforehand. Once converted to a mesh, you won't be able to change the ...


1

You're looking for a feature called "clear coat", which as of this writing (Dec 2019) is nearing the final stages of being added to glTF, but has not yet been finalized or ratified by the Khronos Group. You can track its progress and see some examples in PR #1677 on the glTF repo. There are experimental implementations in ThreeJS and BabylonJS, but it's ...


1

There has been recent development done with blenders gltf exporter, so try exporting with a current development build of blender, you can get a daily build or go to GraphicAll if you don't want to compile yourself. Using a recent build (week old) I can export your blend file to gltf and do not see the issue when importing back into blender, which I do see ...


1

I checked that file, I did that steps: exporting .mdd file, creating a new cube and imported previously created .mdd file. All works fine and animation works.


1

Sorry, this is a known bug, a regression. Issue #425 details it, and a fix is in the works in #506. Sometime in the next few days it should start working again, after that PR gets merged. Also, even after the missing alpha channel gets fixed, you'll still have to specifically enable blending mode per-material. This is done in the "Settings" panel of an ...


1

I'll start off by saying, Blender 2.80 Beta and the GitHub glTF-Blender-IO repository are going to be kept in sync at least through the end of 2.80's release and likely far beyond. So if something new goes in the GitHub master branch, usually you can wait a couple of days and see it show up in a daily build of Blender. There's a version number near the top ...


1

glTF 2.0 has an alpha blending mode available, but it's intent is just to be "coverage" (like medical gauze tape), not a physically correct optical translucency (as the latter was considered too high a target for the initial release of 2.0). Basically this means that low alpha values will dissolve the entire material, including specular reflections. Even ...


1

A couple of issues to note here: The glTF-Blender-Exporter project is obsolete now, superceded by glTF-Blender-IO that includes an importer. The new project can be downloaded from GitHub and manually installed in Blender 2.79x, and it also ships pre-installed in Blender 2.80 Beta. The newer glTF-Blender-IO project can export directly from Blender's own "...


1

Just setting metallic to black(0) and Roughness to white(255) should solve the problem of getting a diffuse shader. I think that your shader is diffuse but you cant see the colors when you export it out. I had the same problem, I solved it by using the Emission node packed with the two nodes you mentioned. All those texts are using emissive nodes. Also ...


1

As of October 2018, glTF 2.0 supports three material types: metal/rough PBR, spec/gloss PBR, and unlit/shadeless. We are working on adding support for the Principled BSDF node to the Khronos Group Blender exporter. That work is in progress, and happening in a new repository (https://github.com/KhronosGroup/glTF-Blender-IO) which includes both an importer ...


Only top voted, non community-wiki answers of a minimum length are eligible