New answers tagged

1

Based on the image in your question, it doesn’t look like what’s causing the issue is refraction, but reflection. It’s hard to tell exactly why you’re getting so much reflection without more information about your specific materials and scene, but there are a few possibilities: The normals on your glass pane could be pointing the wrong direction. Try ...


0

If your emission has a very specific color which is not found elsewhere in the picture, you can also easily solve it by just chroma-keying/color-keying it to get your original mask: (Here I use several "glare" masks to have a stronger effect, but I guess you could use a Gaussian or any other kind of glare)


0

Maybe this:https://www.youtube.com/watch?v=6q-vCT-ZuV8 Or this: https://www.youtube.com/watch?v=fxY4uq8kH0Q tutorial will help??


0

Yeah, turns out I just needed to increase the number of render samples even more. I was originally rendering at 256 samples, and increasing it to 500 didn't make a noticeable difference (hence why I thought the problem wasn't related). But increasing the number of samples even further to 1000 made a significant improvement, and 2000 virtually solved the ...


1

I recommend a simplified setup: You can use the Value of the Transparent BSDF to control the amount of shadow. I have a more in-depth answer to this question that may help as well.


1

As Christopher suggested in the comments, this glass hack has too high Fresnel value that is causing the issue. I'll use a different glass node setup.


3

If you look at reference photos online, it does appear that glass casts a shadow of sorts. What happens is that some areas are darker and some are lighter due to refraction and reflection. In blender, it looks like the default settings don't allow the full amount of light through, so I ran a series of tests. The scene is a simple drinking glass and a ...


0

Why do you have "Lock Camera to View" enabled? If you accidentally have moved your viewport view, then the camera view would also be different, thus changing the render. Simply disable this, and find an optimal spot for your camera, then render. Also, I would recommend using Cycles Render engine for glass reflections, as it is more realistic.


0

I just accidentally found out, i was having a not-displayed older object lying beneath the other object and intersecting at some areas.


1

Make sure that Render Properties -> Screen Space Reflections -> Refraction is on In EEVEE Objects with refraction on in their shader can't be seen when they're behind other objects. Here's the best "fake glass" EEVEE Shader I've found In this shader disable Screen Space Refraction. Set the blend mode to "Alpha Blend" enable ...


1

Try something like this for your "glass" shader. As Nathan mentioned, rasterized transparency will always be lacking compared to Raytracing, and though EEVEE really doesn't like transparency through transparency, this shader attempts to strike a happy medium. Try it and see for yourself. Pay attention to the Blend Modes on the right, including the ...


1

I made a little progress, turning off Filter Glossy to 0 under Caustics seem to have worked. I played around with the other Light Paths after and this is what I got so far: and lamp setting: I will continue the tutorial now, maybe he will mention his Light paths settings at some point.


0

in eevee you can use this setup: -> important is the blend and shadow mode of the material. if you then toggle to cycles, it works as well: and here is the blend file:


Top 50 recent answers are included