New answers tagged

6

A couple of alternatives to @moonboots' perfectly good answer.. The Subdivide operator has a 'Smooth' option in its F9 panel. If that had been set to 1, your cylinder would have been circular when you subdivided it. The Cast modifier, 'Cylinder' option. This works only in local space, and will not be affected by any rotation of an 'Object' you may select ...


5

As an alternative to @moonboots In this case you could use the free looptools plug-in (enable in preferences). Select all the edge rings, and select circle in the looptools options list, see below From: To: In future, when you subdivide a mesh like this and want it to be smooth after subdividing in edit mode, go with: select all edges, edges (dropdown menu)...


5

Select all the circle edges (to make it quick, select an edge ring then Select > Select Loops > Edge Loops), choose Transform Pivot Point > Individual Origins, then AltShiftS > To Sphere and drag (go into the Operator box if you want to make sure it is at 1):


0

If your mesh is not pathological in some other way, (duplicate vertices, inconsistent normals, or somesuch), Intersect Knife should work, to create an edge at the intersection of your faces. However, if the angles are convenient, then you can avoid the calculation of intersections by just snapping the ends of your faces together. With Snap set to 'To: Vertex'...


1

As Vklidu says, these are Faces Sets (there are used as sort of masks in Sculpt mode): To remove them go into the Face Sets panel > Initialize Face Sets > By Loose Parts:


0

Turns out I got blendered The mesh I added somehow spawned asymetrical I kind of overreacted and started seeing things. Everything is in order (with blender at least, I'm pretty sure I'm paranoid). I've seen blender do questionable things before but I didn't know it could troll this hard.


0

So I tried to replicate your situation and I got this: Similar right? Also your problem is not in all those things you mentioned but in basic of how polygons work... If you need for your objects to keep that shape you showed than you should try to select those faces or whole object and in edit mode use CTRL+T to triangulate faces... It will remove those ...


6

If these are 2 separate meshes within the same object, separate them in 2 different objects, you'll join them back later. Enable the Snap tool with these options: Face/Closest/Align Rotation to Target/Move: Then move your object:


0

I fixed it by going to Edit Mode then press A to Select All. After that press Alt + N, then select Recalculate Inside and it fixed my problem.


0

Step by Step Process. Select the face you want to effect, press CTRL + I to invert the selection, press H to hide the faces, Press CTRL + R to create a Loop Cut. after you are done Creating your Loop cuts, press ALT + H to un-hide the faces. now if any face is causing issues With CTRL + R. Step by Step Process. Select the face that is causing an issue, ...


3

I should have made this an extension to the original answer.. but here goes. Activate the shipped add-on Loop Tools After making the I Inset > Individual, use Loop Tools > Circle on all the selected faces, with a 'Radius' set. It's wise to estimate the desired radius before invoking, in this case; the operator is Python, and can be a bit sluggish. The ...


0

Make a joined bmesh. At the risk of not re-inventing the wheel, since blender ships with an OBJ exporter As shown in [find link re joining bmeshes] can read multiple meshes into one bmesh. Start with a dummy vert to move indexing up 1 Update normals after reading mesh to update indices. Possibly other ways to do this. Increment the edge count. Test ...


3

What you're looking for may be the Shear tool: Follow the shape with some extrusions: Extrude and mirror: Shear in order to tilt the surface, the shortcut is AltCtrlShiftS then X in order to move the vertices along the X axis (horizontal) of your view (it would have been Y if you wanted to move them horizontally according to your view): Then bevel, etc:


7

The normals data is messed up. Here's how to fix it.


3

Just increase the frequency. So you will get these results:


0

Okay obviously I should have researched for a little while longer, but for anyone else who has this issue if you see this happen on your model, you need to add the weighted Normal modifier onto your mesh to clean up the visual artifacts, apologies for not doing more research


3

The face you're showing is an ngon, it has more than 4 vertices, so Blender doesn't know what edge it is supposed to cut or select next: You can make it a quad this way (for example):


0

You must have some overlapping geometry. First, select all with A and then press M and select Merge by Distance to remove any doubled vertices. Then you should only have one available top face to move. If the cube was duplicated from another object, that one probably has the same situation.


1

If issue is not yet fixed, I would suggest to change viewport anti-aliasing to Non anti-aliasing from Edit > Preferences - Viewport tab


0

I got it to work. It seems to have been a normals issue, as suspected by Gordon and Moonboots. I recalculated the outside and did some minor adjustments on the topology and now everything works as intended. Thank you very much for the advice.


Top 50 recent answers are included