6

With a little encouragement from @Rich Sedman, copied from comment: The white square looks bigger, because of the conversion after compositing to sRGB for your display device. Arithmetically, inside the compositor, the squares are the same size. If you go to Color Management and switch the View Transform to 'Raw', you can see that. You could use gamma ...


4

Try this: Delete the Compositing tab up the top: Add a new Compositing tab: Fixed! Bonus: You can shuffle tabs around with Reorder to Front to get them back to where they were: Here's your .blend back again:


3

Can also use some RGB curves, maybe (?) Eventually, add another blur (with lower values) after the last RGB curves.


1

Thank you, susu, it was just motion blur. Turning it off fixed the problem.


1

They seem to be very bright specular highlights on the waves : The fact that "Point.001" has a power of 3MW (!) is of course in cause ; but I guess you won't get the same dramatic effect if you lower that value. What you can do is render the waves and the lightning in two distinct View Layers (formerly "Render Layers"), apply the fog ...


1

Solved -- my problem was actually related to Blender's hard-coded behavior in background mode, rather than to something going wrong with the render process itself. In order to get the Viewer Node to work in background mode, you need to modify some source code and recompile Blender as described in the link, because it is disabled by default for optimization ...


Only top voted, non community-wiki answers of a minimum length are eligible