New answers tagged

0

This little box which you can see in your domain represents the "smallest unit" of your fluid. If it is too big, it cannot "see"/recognize your obstacle. So you could either increase your domain resolution and/or increase the thickness of your obstacle. to make it work change this: select your plane (obstacle), add a solidify modifier ...


3

i am pretty sure it is because the messy geometry of your objects. Here you can see: and it should look like this: the edges should be parallel. your sensitivity is much too high: Set it to 0. set shape to mesh apply scale + rotation Hint: your objects have too much geometry. This is not necessary and just slow down the rigid body calculation. i ...


0

I agree with @Ralf and found the problem. In the blend file from @Rich : he mentions setting from Convex Hull to Mesh, but his version of the file did not have this change (perhaps he uploaded the wrong version). However, even this did not solve the problem for me! The solution (not yet making full sense) is to use either "Hull" or "Mesh&...


0

You can either try: Increasing simulation resolution. (Will increase simulation time.) Increase surface thickness on the collider object.


2

You can control when they fall by controlling pinning. You can animate pinning through the use of vertex group modifiers. Create five vertex groups on the simulation mesh. Assign all verts at weight 0.0 to "pinning". Assign appropriate verts at 1.0 to groups "blue", "pink", "green", "yellow". Nominate &...


2

first select your cube, TAB -> edit mode -> A (select all) -> P -> Loose parts. Then change the start simulation frame for each cube as you want. Result:


5

You can solve this by joining both cubes into a single object, so that they use a single cloth simulation, and then enabling self-collision on the physics: I believe that each simulation is its own, independent thing, with the order of the simulations managed by the dependency manager. In your example, the green cube is being evaluated before the blue cube ...


2

When using cloth I had the same issue when recreating your scene. But when using Soft Body it seemed to work. See image below


0

Thank you for providing your blend file which made me curious and easy to help you. If you check these two options here: Collision edge and face -> it works. Before: after: Note: Checking these options will need much more time for calculating your simulation. So maybe a different camera angle might be the quicker solution ;)


2

I got this result by adding a ground plane with collision, adding a plane as emitter with object a subdivided plane. Then I tapped the "make instances real" button on the emitter and hid my emitter in render + viewport. Then I moved all my leaves to a collection called leaves. Then I added cloth to all that instances. Add some wind and turbulence ...


1

Two ways to do this: Use collision collections to control collisions: "Collections" here is kind of legacy; they're not like modern (2.8+) collections. Instead, by assigning a rigid body to one of the 20 collision collection layers in the rigid body settings, you tell Blender that the object should only undergo collisions with objects that exist ...


0

Here a small example with rigid bodies...which is pretty fast with Blender and easy to handle. Some values which are important: friction bounciness collision margin (set to 0) might be as well a good idea to use some forces to "optimize" the falling behaviour.


3

The main reason why the collision doesn't work is that the cable is just a few connected vertices (edges) without any faces. You're using the Skin modifier to give the cable some thickness. That's a good idea but the Skin modifier is below the Cloth modifier on the stack (top-down-wise). This leaves the Cloth simulation still the few vertices and no mesh ...


1

So when physics don't do what I want, I make new physics-only meshes. Okay, so first thing I did here was to look at the collider funnel. The solidify modifier on this was so thin that I'm pretty sure it was confusing the physics, and any softbody verts that made it through the funnel could never recover. So I just got rid of the solidify modifier. After ...


Top 50 recent answers are included