4

You can't see the light object because you've disabled the Show Overlay option (see image below). Also, if you render, you won't see any light, only the light effect and its reflection on objects, if you want to see a kind of light source in your render you need to create an object that will look like a light source, for example a sphere with emission to ...


2

It is because you have simple deform that blends your object around empty. Then you rotate the object empty stays in place, that makes changes in position of empty relative to object. As a result, object blends in the different way. You can parent empty to object (Ctrl+P) or apply modifiers to prevent this behavior. You can also use Add -> Mesh -> UV ...


2

The answer is given by @ChrostopherBennett in the comments of the question. Thank you. Copied: Don't worry, go ahead and use it. Experimental just means it may not be fully flushed out, or they plan on making changes to it in the future (ex: maybe they don't like the way it's fitting with blender and are planning on replacing it with a different module). Or,...


1

...If you forget the Empty, and, in Edit Mode, align the mesh: short-side up the Z of its own Object Axes (displayed in this illustration), and long-side along the X, then a 180 X-bend followed by a 360 Z-bend will work. Modifiers are in the modified object's space by default, so they stay aligned to the object when it is rotated,translated, or scaled.


1

Just go to Show overlays option on right top corner and then turn down the opacity while in weight paint mode


Only top voted, non community-wiki answers of a minimum length are eligible