Hot answers tagged

5

You can choose whatever transform orientation you want to use instead of Local. if you are constraining transforms to some axis with shortcuts x, y, z or middle mouse button, you can just hit it again with Local orientation set to temporarily use global orientation anyway: This works the other way around if you have global orientation selected as well.


5

Basically you have set it so transformations only affect the origin of the object, to disable this setting, go to Options then disable Origins There is also a very similar looking thing that one can accidentally enable under Gizmos > Object Gizmos


4

As far as I know object scale can only be done along its own axis (X, Y and Z). So if we have this cube orientation (rotated 45 degrees around Y for instance): it cannot be scaled in the global Z axis only. That's why we have this result: So to obtain the wanted diamong shape, you need to either: Apply rotation CtrlA and choose 'rotation'. Then scale ...


3

In Edit mode, "Align View to Active" will align your view to the active selection's LOCAL axes. https://docs.blender.org/manual/en/latest/editors/3dview/navigate/align.html


3

Updated based on the comment: The option you look for is the "Orbit left" using the Numpad 4 and "Orbit Right" using Numpad 6 respectively. At least in my logic that is the only way to rotate the viewport(as in the title of the question) and is not leaving the xy-plane. Not sure how "Roll and Orbit is different here as the result seems to be the same. The ...


3

You can do one of two things: You can select the 'Move' tool in the toolbar (T) or press Shift+Space> G: If you would like the gizmo to appear regardless of the tool you have selected, click the 'Viewport Gizmos' button in the 3D View header, enable gizmos for active object by enabling the 'Active Object' option and then enable the 'Move', 'Rotate' or '...


3

There's the Toggle Quad View option, which has such functionality. It splits your viewport into multiple views, that cannot be rotated. View > Area > Toggle Quad View Shortcut: Ctrl + Alt + Q


3

You can enable Snapping by pressing the magnet at the top of the screen. If you click on the drop-down menu next to the magnet icon, you can change what Blender will snap to. To toggle snapping via a keyboard shortcut, press Shift+Tab. Pressing Ctrl+Shift+Tab will bring up a pop-up menu for changing the snapping object. If you don't want to toggle snapping,...


2

The Solidify modifier like many others, can be assigned to a Vertex Group. In the case of Solidify, the vertex weights affect thickness. If you paint a linear gradient down the right axis: Then there's quite a lot of tweaking-room left in the Solidify's 'Thickness' and 'Factor' settings .. maybe enough to get the precision you need?


2

In short: armature properties/viewport display/axes


2

There is a rule to give the proper orientation: The particle object is considered along its Y axis and this is the axis that will give you the Z (say Z for now, but see below) on the mesh the particles are. So if you want the carrots to be up (Z), you'll need to change them in edit mode so that what will be Z as particles is Y for the carrot mesh. On the ...


2

Click this icon (see image) or shortcut Altz


2

You can check Only Origins to only transform the origin point. It's in Sidebar > Tool > Transform, Shortcut: N Then you can rotate the local axis, without affecting geometry.


2

As commented by @RobertGützkow, you have Snapping enabled: That means your vertices will be snapped to the closest face while moving them. You can disable it altogether or hold CTRL while moving.


2

make a 3 x 3 rotation matrix with X, Y and Z axis as columns. Blender matrices are in rows, so will transpose rows to columns. The X axis is Y.cross(Z). Make the matrix a 4x4 transform matrix and set its translation to coordinate Note Added a scale factor so location 1000 -> 10. To avoid clipping. Set to 1 or remove. import bpy from mathutils import ...


2

You have Origins enabled in the Transform menu. Just uncheck it and those annoying axis will disappear. (The gizmo shows for each of your 583 selected objects)


2

This usually happens, when your object has non-uniform scale. You need to apply scale first for a correct UV unwrap. Object > Apply > Scale Also, make sure your texture is connected to the UV map


1

To put objects back into World origin, you need to reset their transforms. You can do it for both Donut and Icing at once. Shift Drop the Icing onto the Donut in the outliner. So they move together. Select your Donut and clear all transforms one by one. This will put both in center. Select Icing and clear Parent relationship (Alt+P). Then go Object > Apply >...


1

If the orientation of a bone is not correct you can change it in Edit mode with ctrlR (manual), or ShiftN (automatic). To display the axis go in the Properties panel > Object Data > Viewport Display > Axes. Now if you want a bone to influence the rotation of another bone, in Pose mode, you can give the second bone a Copy Rotation constraint (in my case ...


1

In bones Y axis is always the longitudinal axis, and this cannot be changed, but you can extrude from its head another bone, orient it as you want (along with world coordinates I guess) and the set it to be the parent of the deforming bone.


1

[Object mode] Select the object. Shift+S > Cursor to selected. This way we'll ensure the transforms are done relative to the object pivot point. Change Transform Pivot Point to 3D Cursor. [Edit mode] press A - it selects everything. Then press R followed by Z, X or Y, whichever axis you need to rotate object around and type 90, confirm with Enter (that's 90 ...


1

There is also an 'Axis' option in the Object Properties tab > Viewport Display panel.


1

Some brushes have this option in their properties panel, but the grab brush doesn't seem to follow its instructions, and it seems to be always view-related.


1

Of course there is a way. Just click the gizmo, instead of dragging it. Then use the pop-up menu to adjust the values, and the gizmo stays visible.


1

To rotate multiple bones around their local axis you have to set the following. The Pivot Point has to be set to Individual Origins, since the bones should rotate around their "individual" origin each. The Transform Orientation has to be set to Local. Otherwise the bones would be rotated around the global axis which is the same for every bone, regardless of ...


1

A script to do this Used as answer to Calculating and exporting global rotation of faces created from splitting an isosphere (possible dupe?) thought it would be good here too Shows origin and local orientation of one split off face Adds an icosphere, edge splits, separates and returns to object mode Selected objects are the result of separate modifier. ...


1

Numpad 7 is the shortcut for top view, Ctrl+Numpad 7 is the shortcut for bottom view. Same for Numpad 1/Ctrl+Numpad 1 (front/back), Numpad 3/Ctrl+Numpad 3 (right/left)


1

Create an empty and turn on face-snapping with influence on move and rotate before snapping it to your rotated plane(empty is aligned): parent the rotated plane to the empty and finally set the rotation of the empty as 0, 0, 0 before clearing the parent-relation: explanation: the problem with the snapping without the empty is that there are no object ...


1

As a first shot, if you have used a 'Follow Path' constraint, -Z tracking, Y up, then ensuring the Tilt of all the curve's control points is set to 0, and setting the'Twist Method' to 'Z up' in the curve's Data tab > Shape panel should be enough.


1

This is due to the extra edge you have on the top surface. You can enable clamp (hold Alt or press C) after sliding the edge far away from it, but it's not perfect. Removing the edge works best, if you don't need it: To get an edge where you've indicated, you might find it easier to use the knife tool, at least in this case: Line up the view with the ...


Only top voted, non community-wiki answers of a minimum length are eligible