New answers tagged

3

Enable Transparent Film under Render Properties > Film > Transparent HSV node to make B/W. Blur node to soften edges of shadow. Translate node to offset shadow. In my case 5px right and 10px down. Set Alpha node to reduce opacity. All of above nodes can be tweaked to your liking. I have used an Alpha Over with a blue colour for a background, but this ...


2

To create a good base for weight painting you can a dummy model, calculate automatic weights, and transfer the weights to the original model with the menu entry Object > Link/Transfer Data > Transfer Mesh Data (in Object mode). This operation does the same as the Data Transfer modifier and copies the weights from the active to all selected objects. The ...


2

Yeah, figured it out. Like @Nathan said, I should have just weighted the entire vest and changed the order of the modifiers. My bad. Question Closed.


0

One way you can do is (if you didn't do any weight painting on your mesh until now): Select your object, Tab -> Edit mode, then delete all your head vertices. Tab -> object mode. Move your "new" head to its position in object mode. Select your new head, Shift-select your body, CTRL-J to join. Then Shift-select your armature, press CTRL-P ->...


2

You could do it with some shapekeys and with a driver: Create a cube, subdivide it, give it 2 shapekeys (one basis and a second one), keep the second one selected, go in Edit mode and round your cube with AltShiftS (make sure that the factor is at 1 in the Operator box): Create an armature at the middle of the cube or wherever you want (parent the cube to ...


2

Particle Systems and Armatures are applied as modifiers, so modifier stack order counts. Make sure the Particle System is after the Armature.


2

If weights are 0 (if vertex groups are empty) the mesh will not move. In edit mode select all vertices of a section of your mesh (i.e. left hand), select the relevant vertex group (maybe hand.l) and assign a weight of 1.0. Do the same with the rest of the body. Then use smooth brush in weight paint mode to soften the transitions.


0

If you go into the shader tab, you'll see a material called MBlab_generic and then whatever the asset name is. Go into Edit Mode and click the Select button with that shader highlighted, it should select all the faces that have that black shader. Select your skin shader and click Assign, it should then assign that shader to the black sections.


3

From the screenshot, it looks like the bones' heads (roots) are at the right place, but only their tails (tips) are somehow far away. This looks like a rig from an external program that has been badly imported to Blender. Some programs don't have notions of start points and end points for bones, they are just unique points. That's why sometimes you have &...


0

What you want isn't impossible. It is impractical though. In general, for any given local area of a mesh, you either deform it via bones, or you deform it via shapekeys, not both. That means you can have eye shapekeys with a head bone, but not eye shapekeys with eye.01 etc bones. That's the practical way to do it: if you want better control, just use ...


0

If we start with bones that lie in a plane, and we only ever move our IK target in that plane, then the bones will never rotate out of that plane. Topmost is rest position: So then all that we have to do is specify the plane we want them to lie in by orienting the parent the of the first bone in the chain. However, you might not just want them to lie in a ...


6

The issue here isn't the rig. As you can see, the rig behaves the same on both sides: What is different is how the mesh is deformed. If you go in Weight Paint mode, you will see that the toe area is assigned at full weight bot to your toe group and foot root: The solution is to remove the toe part from the foot weights. Since you have it selected in Edit ...


2

Using 3D cursor for this is a quite classical way, but there is an easier method, using snapping: Using 3D cursor is useful, though. For example, when you need to snap at the center of a circular shape.


3

It's the way rigging is supposed to work, if your vertices are only part of one group, even with a weight of 0.001, they will move as much as vertices that are part of the same group with a weight of 1. If they are part of several groups, the influence of the bone will be propotional to the weight. If a vertex has a weight of 1 in vertex group A and 1 in ...


2

in rest pose add Empty at tip (tail) of your EndBone IK Constraint on EndBone > Target = Empty, with Rotation enabled Bone Properties > Invers Kinematics > Lock XYZ


0

Ok, if i understood you right, just just want to "offset" your target, right? remove IK controller from bone 6 select bone 6, tab for edit mode, select its tail, press E Z to extrude a new bone Note : Be careful, that you really get bone6 selected - i had to click twice on its tail to get the right bone. The name should be bone7, then you got ...


2

Check if anything is disabled in the bone layers under the armature's Object Data Properties.


0

Create 2 new vertex groups, one containing only vertices you want to preserve volume, the other all others vertices. Add a new armature modifier targeting your rig, and use the vertex group limit function to have the desired result. Another method using one new vertex group only:


0

The reason for this is because those bones that you reparented have a bone constraint to the root bone which also applies the transform. Go into Pose Mode then under Rig > Pose > root > [reparented bone] > Constraints > SWITCH_PARENT, disable it with the eye icon. You can also select the reparented bone and go to the Bone Constraint Properties ...


0

No wonder why the bones are not aligned with the mesh in Pose mode, they are not aligned in Rest pose either. You need to realign them in Edit mode:


1

For who still want to find a solution now, and assuming you want to do this in Blender (not scripting). In Blender 2.93 select your armature, go to Pose mode, press N on your keyboard to bring up the panel, in Tool enable X-Axis Mirror. Then you're good to go.


2

So in 3D, gimbal lock isn't really some kind of lock, that happens at one specific orientation, like it is in engineering, which is where the term comes from. It's really just wonky Euler interpolation that exists at all orientations, but is most apparent at certain orientations. It's not some special thing that happens sometimes; it is always happening, ...


0

It depends by the rig structure, it's impossible to tell without seeing the rig, but you can add a bone in edit mode, put it in the same location as the bone you want to rotate, set its rotation as desired and make it parent of the previous bone, so that the spring effect will be transferred. You will have to set the new bone as child of the parent the ...


2

The quickest way might be the Drivers Editor. Open sidebar (N-Panel) and select tab Drivers. Deactivate 'Show Only Selected' in header and expand all channels. When a driver is clicked the targetbone is displayed in Sidebar > Driver > Bone. This must be done for each driver to see all bones. Not really sexy, I think. Let's do it with python. In ...


0

Found the problem. The file was saved in Blender 3.0 while I was trying to load it in Blender 2.9 (correction from original question in which I said 2.8). After updating blender to 3.0 the issue was fixed


0

The mesh gets deformed if: it has an armature modifier targeting the rig the mesh has some vertex groups with the same exact name of the bones of the rig, and some vertex weights assignements the rig is in pose position and not in rest position The most common problem of breaking the rig is when you import a datablock into a file which has already another ...


1

A broad use of this kind of structure is sometimes called "Socket", in which Bone A is child of bone B, and bone B is constrained by Bone C. In this way when you move C, bone A and B will follow, but you still have the freedom of adjusting bone A (while bone B is constrained and maybe can't be directly moved). As you're interested in rigging, I ...


1

Some cubes are assigned to some vertex groups that they should not be part of, so select all the head cubes, go into the Object Data panel > Vertex Groups list, and Remove from All Groups: Then assign them to the group that has the name of the bone that is supposed to control them (Bone.001): It works:


1

Since you have an IK, it should be relatively easy: just set the IK controller's parent to the root instead of the hips. BUT, ideally, you want to be able to use both depending on the situation. In which case, you also want to add Child of constraints to your IK controllers, pointing to your hips controller. Then you can turn that constraint on and off via ...


1

Generally you need to exit edit mode for changes to be applied. It works the same way for meshes actually. For example # Make sure the armature is the thing you're editing bpy.context.view_layer.objects.active = arma_ob # Switch to edit mode if bpy.context.mode != 'EDIT': bpy.ops.object.mode_set(mode='EDIT') # Clear all rolls for editBone in arma_ob....


1

Meta-Rigs Rigify uses the so-called Meta-Rigs to generate the actual rig. The Meta-Rigs is used to tell Rigify where the bones are located and how your model looks like. The generation of the rig fails because you try to create a metarig armature from scratch and haven't defined any of the needed rig types for the bones. These define various parts of the rig ...


1

Your parentage actually failed. What you need to do is: Delete all the vertex groups (in the Object Data panel > Vertex Groups list, down arrow button on the right > Delete All Groups) Some normals are inverted, select your object and in Edit mode, select all and press ShiftN in order to recalculate the normals. You have overlapping vertices, select ...


0

take a look at this answer. I've explained whatever you need about matrices in blender


1

It looks like you've accidentally assigned the same action to both the object and the armature when you actually need to assign it to the armature only, as it is controlling the object. To remove the action, select the object (gun), open the Dope Sheet, switch it to Action mode, click on the X button, it won't delete the action, it will just remove it from ...


2

It's important that there's nothing that makes bones use some weird coordinate space where the base orientation is Y-up, unlike everything else. They exist in the exact same space as anything else. It's just that when you add new ones, they come out of the tin pre-rotated for you. I think you understand this already, but it's worth mentioning for others. ...


0

In Pose Mode select all bones, Right Click and choose Clear user transforms, the very bottom option.


0

Unfortunately the answer to your question is spread across several file in blenders/source/blender/editors/armatures; isn't trivial; and isn't documented in a single place. The most interesting bits are in pose_transform.c starting around line 103 Perhaps this answer to a related question (How to make pose bone rotation toward a point?) might be helpful.


4

In Rigify rigs eyes are supposed to be a separate mesh (if not, select an eye in edit mode and press P to separate it from the rest). Then select the eye, shift select the armature, activate the 30th bone layer, select the MCH-eye bone (the only one which has a little target bone on its tip) and press Ctrl p > Bone. The same applies to teeth, in this ...


1

It sounds like you disconnected the spine chain somewhere... or maybe you connected a bone that shouldn't be connected. The rule for the individual Rigify parts is: All bones of one "rig type" must be parented and connected. Individual rig types can be parented but not connected. I hope this makes sense. From what you describe, enabling "...


2

These disconnected arms don't impact the rigging much, it actually make it simpler. You could just use Rigify the usual way. It's just that the arms par of the rig will have no mesh to deform, and that's OK. It is actually interesting to keep the arms in the rigging: when you want the hands to have a natural movement, you will animate with invisible arms ...


Top 50 recent answers are included