Questions tagged [versions]

Questions about using and managing different versions of Blender, past present and future. Use this tag for upgrade questions, installation questions, etc.

Filter by
Sorted by
Tagged with
17 votes
3 answers
5k views

Where can I get Blender test builds?

I know that Blender.org provides downloads for official releases. I see on forums that people use newer versions of Blender. Where can I get newer version of Blender (nightly builds, alpha versions... ...
13 votes
3 answers
4k views

Is it advisable to update Blender to the newest version as soon as possible each time?

I know Blender is free software and bugs happen. But my question is, is it good practice to update Blender every time there is an update? Even if a minor one? (i.e I'd consider 2.56 to 2.56b minor or ...
9 votes
3 answers
13k views

How to duplicate an object in 2.8 via the Python API

I know how to successfully duplicate an object by using bpy.ops.object.add_named(name = 'TemplateObjectName') If the template object named 'TemplateObjectName' ...
Dazotaro's user avatar
  • 901
22 votes
8 answers
176k views

Updating to latest Blender version

I currently have version 2.74. How do I update to version 2.76? I do not see any links in the UI to update my version of Blender
Ntxdave's user avatar
  • 221
6 votes
2 answers
3k views

What is the proper way to update a portable Blender installation while keeping user settings?

The Windows portable installation has (or can have) the user settings folder (named '2.77' for instance, containing all the user preferences) next to all of it's files - which is perfect for me, since ...
PLyczkowski's user avatar
8 votes
4 answers
17k views

How to run Blender through RDP on Windows Server 2008 R2 - opengl error

I want to render my blender project in rdp. But some error has appeared. What is the best solution for this problem? I've spent many hours trying to troubleshoot this problem.
Devz's user avatar
  • 81
6 votes
3 answers
21k views

Blender build for Raspberry Pi3?

Has anyone tried installing blender on a Raspberry Pi 3 or do you know which version of blender will be supported on Pi3? If I get just the 3d view running for modeling, that'll be great.
iowaqas's user avatar
  • 466
6 votes
2 answers
7k views

Transfer settings to new version of Blender

I use Mac OSX 10.9.5. A year ago, I downloaded 2.75a, and today, I downloaded version 2.77a. I downloaded both via .zip file from blender.org and dragged each into the Applications folder of my Mac. ...
Aubrie's user avatar
  • 707
6 votes
1 answer
2k views

How to Enable Frame Blending in Blender 2.74?

I can't find the option that supposedly existed in Blender 2.49: "Enable Frame Blending". Does anyone know where it is, or where is its analog? I shot a sunset - 30 minute video I want to turn to 10 ...
Sergiy Migdalskiy's user avatar
5 votes
1 answer
5k views

Thoughts on Building a Blender-Oriented PC [closed]

The rendering time on my laptop is starting to become absurd in order to get a decent looking scene. I am looking at building a pc that is well suited for blender. What components are the most ...
rain's user avatar
  • 519
4 votes
4 answers
14k views

How to configure which Blender version opens when clicking on a .blend file?

If I double click a recent blend file icon, the version of Blender that it calls is an old one. The file was created using 2.76, but if I double click it it runs inside 2.72b. If I right click it ...
The Beachdancer's user avatar
2 votes
1 answer
1k views

How to build Blender as Python module? [duplicate]

I'm on a Linux Ubuntu 18.04.1 LTS System. As the title states I was unable to find any precise documentation how to build blender as Python Module for uses in scripts. If anyone can help me I'd ...
Chgad's user avatar
  • 255
15 votes
7 answers
19k views

Is there a way to update Blender without deleting it and downloading the new version?

I like to stay up with the latest version of Blender. I use Blender on my Macbook Pro and it is kind of a pain to update Blender because you have to delete it and then re-download it. This isn't a ...
John's user avatar
  • 3,567
6 votes
1 answer
489 views

Blender release life cycle and versioning

I was trying some older versions but version numbers and release versions are not clear to me. For instance how can I know what is the most stable release of a given version, say 2.49: The folder ...
rraallvv's user avatar
  • 4,551
5 votes
2 answers
4k views

Blender 2.81 32bit

Will there be a version of blender 2.81 for 32bit windows as there was for 2.80? In my working environment we are currently ...
MattB's user avatar
  • 153
5 votes
2 answers
519 views

What is the difference between Blender Version X.Y.0 and X.Y.1?

What is the difference between Blender Version X.Y.0 and X.Y.1? For example, between Version 3.6 and 3.6.1. Are these just bug fixes or something? Or are there some relatively significant changes? ...
The Kalaakaar's user avatar
5 votes
3 answers
5k views

How to get my file back in 2.79 after saving with 2.80 series?

I was experimenting with a file in 2.8 and accidentally saved it. When I opened it back in 2.79 I can't see my model. It disappeared with the error File written by newer Blender binary. How can I ...
atek's user avatar
  • 10k
5 votes
1 answer
2k views

Learn Blender 2.7 now or wait for the 2.8 Beta release? [closed]

Is Blender 2.8 different enough that I should wait for the beta to be released (in a couple weeks?) to start learning the software, or is 2.7 a worthwhile starting place?
WasteTimeMachine's user avatar
5 votes
2 answers
6k views

Where is the render display mode setting in 2.8?

In 2.7x and earlier we have a setting which controls where the rendered image is displayed when F12 was pressed. The setting can still be set via the python api (...
gandalf3's user avatar
  • 157k
2 votes
1 answer
6k views

Exporting from Blender to Browser (Web Viewer)? What is the best way?

Currently I have modeled 3D products in version 2.83 of Blender, using cycles as a rendering reference. And I have been using version 2.72 to create Web view pages (.html) of these objects, with the ...
Gabriel Magalhães's user avatar
2 votes
1 answer
11k views

Can you easily export a .blend to a previous version of Blender? [duplicate]

I have 2 versions of Blender, 2.79 and 2.9. I edited a .blend file that was made in 2.79 today in 2.9, then saved. Now, I cannot open it in 2.79 anymore (it just crashes Blender). However, there are ...
MicroMachine's user avatar
  • 4,611
1 vote
1 answer
10k views

How to update Blender 2.8?

Haven't used blender for a while. Do I still have to delete my current blender and download new one from the webiste?
Ruslan Plastun's user avatar
1 vote
2 answers
2k views

Unable to copy objects between versions

I can't copy and paste objects between versions which is an issue because older blender crashes trying to open newer blender files and newer blender warps models from older blender on scaling
hiwa's user avatar
  • 11
26 votes
5 answers
6k views

Do .blend files store information on which version of Blender they were created in?

I'd like to know if a .blend file contains information about the version of Blender it was saved from. I have couple of old files and I'd like to open them in ...
Utas's user avatar
  • 844
9 votes
1 answer
260 views

How to build and submit Mac builds to Graphicall?

I've used a few of the custom builds on Graphicall, and I'd like to give back by helping contribute some back. I've got a Mac, which is a bit of an underdog in terms of building submitted, and I've ...
MidnightLightning's user avatar
5 votes
1 answer
2k views

Context Problem in Blender 2.80 python module

I run Blender 2.80 as python module (for running on a server with Django), so there is no gui. Apparently passing the correct context doesn't seem to work for me in this case. I have tried many ...
Robert Roth's user avatar
5 votes
2 answers
28k views

What version have I installed

I read that MB-Lab 1.7.5 requires Blender 2.80.74 or later. I cannot find what my exact version is, it just says 2.80.
Pablo's user avatar
  • 71
4 votes
1 answer
172 views

Move a project from 2.93 to 3.0 without causing issues

I have some projects created with 2.93 version. Because of the speed of CycleX, I want to continue my project in 3.0. In this post , it was said that it's better to continue in the same version to ...
Barbod M's user avatar
  • 570
4 votes
2 answers
2k views

Blender 2.72 "blender-app.exe"

Blender version 2.72 in the .zip downloaded from blender.org there is a new file called blender-app.exe in addition to blender.exe. What is blender-app.exe for? Which file should I use to open ...
David's user avatar
  • 49.3k
3 votes
1 answer
1k views

Missing objects from old Blender in 2.8 (hidden in 2.79b and lost in 2.8) [duplicate]

I am missing a bunch of objects when opening some old blender files (it has nothing to do with the collection visibility like in this post: Missing objects when opening old file in blender 2.8) I ...
Stefan Möller's user avatar
3 votes
1 answer
939 views

Why is the Steam version of Blender taking so long update?

I got the Steam version of Blender hoping to get new updates downloaded automatically but it's been days since 2.76 has come out but I still haven't gotten the update. Are steam updates delayed for ...
Chickenator's user avatar
  • 1,803
2 votes
0 answers
455 views

MANTAFOLW - Realistic Dirt/Dust trail

I'm following the "Making Realistic Dust trail" question which is not accurate for today blender smoke sim interface. I try to reproduce this answer for cgslav but in blender 2.9 which does ...
Ahurig's user avatar
  • 21
2 votes
2 answers
8k views

Where can I download older versions of Blender?

I was trying to re-download the original Blender 2.8, however it goes directly to the 2.81 download page instead. How can I access downloads for previous versions of Blender and installers for older ...
AnthonyW's user avatar
2 votes
1 answer
555 views

Where to download older Blender versions? Namely Blender 2.80

Where to download Blender 2.80? I downloaded Blender 2.82a but it always crashes. So I'd like to try 2.80 but I can't find it on the official Blender site.
Kerem Yemenici's user avatar
2 votes
1 answer
5k views

Why is the smoke preview not showing in Blender's viewport?

I've been trying to put together a smoke sim in blender 2.74 using the quick smoke preset however have found that it does not show up in the viewport, yet will still render. Long story short i have ...
Hexbob6's user avatar
  • 2,038
2 votes
1 answer
1k views

Blender 2.8 causes all other versions to not run!

After installing 2.8 i use it for 5 min then it stops responding and crashes. I try to reopen and the console is blank and it never ends up working. All other versions of blender i have installed also ...
Riley Christian's user avatar
1 vote
2 answers
2k views

Will add-ons from Blender 2.79 work or be compatible with Blender 2.8?

The add-ons I use are part of my workflow so I'd like to know if I'll still be able to use them with Blender 2.8. But if nobody is sure, is there a way i can find out?
Ham N Bacon's user avatar
1 vote
0 answers
61 views

How do I migrate an addon from 2.93 to 4? [duplicate]

On the topic of duplication I don't think this is a duplicate of the suggested post, although the contents of it may be helpful. The issue of converting an addon to run on Blender 4 is not going to ...
MisterLBlends's user avatar
0 votes
2 answers
3k views

How do you download Blender 2.79

This is Yusamac205. I have been going through all of these different links that are supposed to download Blender 2.79 beta. But am unable to do it. Here are the links I have tried, with the ...
HappyBlenderUser's user avatar
0 votes
1 answer
686 views

Blender 2.8 Mac OS , modifiers tab missing? [duplicate]

Hi I was using previous versions of 2.8 and now version available today, does not show the modifier tab on the right. I might get lost on UI updates?
Bruno Suraski's user avatar
0 votes
0 answers
80 views

Downgrade to what version to cover most tutorials?

I'm following a tutorial[0] to create scratches. I'm using 2.92 while the tutorial is 2.8 and I'm stopped due to differentiating node settings already at the beginning e.g. voronoi. Since I have to ...
jjk's user avatar
  • 980