1
$\begingroup$

I cannot find any other posts to do with this and I don't to completely mess up my Blender while messing with settings I do not understand. I finished putting a video together in VSE and tried to render it and I got this error: The encoder timebase is not set .

How do I fix this? Also I am happy with a workaround such as copying my VSE strips to a second Blender window but I don't know how (Yet again) :) . Thanks

Edit: It seems to be something to do with FFmpeg because when I switch to an image format it renders fine. I will try removing the audio codec (mp3).

$\endgroup$
  • $\begingroup$ Hmm, thats weird. What are your output settings for ffmpeg? Did you try another Codec? I know that Blender's .mkv files seem broken $\endgroup$ – 3pointedit May 14 '18 at 4:16
  • 1
    $\begingroup$ @3pointedit can you write a bug report about this, including how to reproduce this brokenness of .mkv? developer.blender.org $\endgroup$ – dr. Sybren Jun 17 '18 at 8:20
  • $\begingroup$ @experimental-rocket can you install ffmpeg and paste the output of ffprobe file-that-causes-issues? $\endgroup$ – dr. Sybren Jun 17 '18 at 8:22
  • 1
    $\begingroup$ @dr.Sybren I have checked a recent build of 2.79 on the 7th July and can no longer find an issue with .mkv files. Sorry for noise $\endgroup$ – 3pointedit Jul 6 '18 at 6:17
1
$\begingroup$

It was the frame rate i used screen capture for the video file uploaded to Blender and got the message "the encoder timebase is not set" Error, when I checked the frame rate it was Custom 30.06 FPS I changed it to 30 FPS and everything worked perfectly.

$\endgroup$
0
$\begingroup$

Try transcoding the source media first, it could be that Blender's ffmpeg just doesn't like the codec settings. Use an external transcoder to fix it, like mpegstreamclip or even VLC (its a bit flakey though). This can happen with variable frame rate recordings, like you get with some screen capture software.

I suggest moving the original media out of its folder then put the new copies in their place, as long as the names match then Blender should be able relink to these clips.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.