0
$\begingroup$

I try to remodel a asset store asset. I have used the project knife tool and now I try to add new faces to that cut out. I select four vetices and press F but it affects the UV of close by faces, see screenshot

Before enter image description here After enter image description here

Thats a backface and shouldnt have UV at all.

edit: Ok so I followed this tutorial to get better topology https://www.youtube.com/watch?v=axCYMBRMXo0

It now looks better, but there is some strange changes here is the original model in unity, see how the reflection is applied to the PBR material enter image description here

Now after my changes enter image description here

My typology now looks like this enter image description here

$\endgroup$
1
2
$\begingroup$

What you are seeing is Blender's smooth shading view trying to smooth out the appearance of the faces. Whenever you add new faces, you give Blender more faces to try and shade smooth. Before adding the face, the original face was an edge. Now you are telling Blender that it is actually a corner, and thus the shading is updated. Now, the other reason for how the shading looks is that the original face is an ngon, so it has more than 4 faces. Ngons are much more prone to shading issues, as they have to be triangulated before rendering, and this can lead to unexpected behavior. Especially in this case, you should try to avoid them. Look into trying to clean that up and make your topology better. There are plenty of resources out there for that, both on this site and elsewhere.

$\endgroup$
5
  • $\begingroup$ Can I somehow tell the knife project not to create these problematic ngons? $\endgroup$
    – Anders
    Jan 28 '18 at 20:27
  • 1
    $\begingroup$ No. The knife project toll has no options like that. You will have to manually clean up your geometry by connecting the new vertices to form nicer faces. You can try selecting the ngons and using Ctrl-T to turn them into triangles, but that might not be any better. $\endgroup$
    – Brenticus
    Jan 28 '18 at 20:50
  • $\begingroup$ Please see edit to original question $\endgroup$
    – Anders
    Jan 28 '18 at 20:54
  • 1
    $\begingroup$ Your topology could still use some work, but it's definitely better than ngons. Good topology takes practice, so don't give up yet. The material change is (I think) because the normal map that applied to the whole object now doesn't apply to the new section. The normal map is what is making the rest of the object look slightly rounded, which gives nice highlights. The new section is perfectly flat, which is why it looks off. If you wan't help with that or a better understanding of why that is happening, that would be best left for a new question. $\endgroup$
    – Brenticus
    Jan 28 '18 at 21:06
  • $\begingroup$ I used the UV from that old section for the new though $\endgroup$
    – Anders
    Jan 28 '18 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.