0
$\begingroup$

I am trying to add a texture to a simple mesh with a front and back side. I have mapped several similar meshes without problems but this one is stumping me. For some reason the "back" texture is reversed and I cannot get it corrected. I have tried reversing UV's, flipping normals, and UV unwrapping from both the front and back view (not sure if that does anything). I tried all combinations of the aforementioned, to no avail. Any clue as to what I'm missing here? enter image description here enter image description here

$\endgroup$
1
  • $\begingroup$ The render behaves the same as viewing the material in the viewport. I've uploaded the node screenshot. $\endgroup$ Jan 26 '18 at 22:21
2
$\begingroup$

It seems to me that the issue is that you are using an object that has no thickness and the front and back faces are the same.

You can use the backfacing information of the geometry node to assign different textures to the front and back of the object.

To flip the texture on the back side use a Vector>Mapping node, and set the backface's scale on the X axis to -1

enter image description here

$\endgroup$
1
  • $\begingroup$ Thanks for the suggestion, after a closer look of my texture image I realized that I created it incorrectly. Thus I'd never get the texture to work correct (smacks forehead). $\endgroup$ Jan 29 '18 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.