0
$\begingroup$

My environment and render settings all seem normal, and when I go into rendered mode(Shift+Z or preview mode dropdown menu) it looks fine and lights the scene normally, but when I do a test render of the final frame, the environment disappears and doesn't light the scene or show up in reflections. I thought it might be my compositing setup somehow, but it looks like that while it's still doing the initial render, and I tried just plugging the rendered image into the final image slot to test it and it still looks the same.

Screenshots:

preview and render settings part 1

part 2

render and environment settings

compositing and camera settings

$\endgroup$
  • $\begingroup$ You probably excluded environment from the current render layer. $\endgroup$ – Duarte Farrajota Ramos Jan 26 '18 at 18:54
  • $\begingroup$ In what setting? $\endgroup$ – Jackson Roberts Jan 26 '18 at 20:20
1
$\begingroup$

Enable Environment in your render layers:

enter image description here

set film to transparent:

Composite over the background using alpha over:

enter image description here

$\endgroup$
  • $\begingroup$ The environment pass still renders as black, and still doesn't light the scene. $\endgroup$ – Jackson Roberts Jan 26 '18 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.