2
$\begingroup$

I don't know how old is this bug, but it seems that the circle tool on LoopTools addon is giving weird results:

enter image description here enter image description here

All vertices are coplanar and no transforms exist on the object. How is it possible that some selections turn into the same plane and others don't? (selecting one by one and applying the tool gives the same result)

$\endgroup$
  • 1
    $\begingroup$ More information about your object, or a gif of this occurring might help to determine why this is happening. The operator works fine on my system. Sometimes setting pivot point to individual origins (Ctrl+.)seems to be useful, although not necessarily needed I guess. $\endgroup$ – Timaroberts Jan 26 '18 at 18:09
  • $\begingroup$ it's not model-related. I tried the simplest thing: creating a plane on an empty scene and giving it a try. surprisingly, it only works if the plane is facing the Z axis. after rotating it and applying rotation in any axis, it stops working properly. I'm using blender 2.79 (2017-09-11 10:43 release) $\endgroup$ – arvere Jan 30 '18 at 9:47
1
$\begingroup$

So far as I understand, there are 5 possible reasons:

1.) LoopTool's Circle menu settings may be the culprit:

LoopTool's Circle Menu

The settings used restrict it's alignment. Try other combinations.

2.) Duplicate vertexes and/or lines. LoopTool's tools depend on nearest-neighbor objects. This may indicate that the mesh needs cleaning.

3.) Multiple plugins may cause undesirable operation. Try removing other enabled plugins and try again.

4.) Possible driver conflict. Verify that the drivers your system is using is compatible and up-to-date. You might also need to use an older version of a compatible driver for stable operation.

5.) Faulty Blender - A fresh installation of Blender may be needed. Also verify the storage device you load it from is in good condition, and is properly connected.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.