1
$\begingroup$

I'm a newb to blender so apologies if this is obvious. I modelled a simple cup and set the modifier subdivisions to 5 after I turned on 'smooth'. It renders fine in the CTRL+Z render preview window but when I do a final render the handle of the cup is blocky and not smooth.... Any ideas what I'm doing wrong?

Attached pics of the render with blocky handle and the object/render settings

Many thanks

enter image description here

enter image description here

enter image description here

$\endgroup$
  • 6
    $\begingroup$ Toi have 5 subdivision levels for preview, but only two for rendering. Bring up the value so that you get more subdivision for rendering $\endgroup$ – cegaton Jan 23 '18 at 20:22
  • $\begingroup$ Ahh yeah, I totally forgot! Thank you very much! $\endgroup$ – obloquy Jan 23 '18 at 20:26
3
$\begingroup$

Well, Cegaton already found the problem, but the question needs an answer for future users.

The Subdivision surface modifier has two important parameters: the view and the render subdivisions. As their name suggests, view determines how smoothed out the surface will be when viewing it in the viewport, and render does the same for rendered images.
Modifier

This is useful if you want a smoother object when rendering, but want a better performance of the viewport and don't need much detail when previewing – you can set a lower view and a higher render.

If you set the render parameter lower than the view parameter, objects will appear smoother in the viewport than in actual renders.

Another possible cause of this problem is that the modifier is visible eye but isn't being rendered camera. In that case, click the camera icon to enable rendering of the modifier (in the image above, both rendering and viewing are enabled).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.