0
$\begingroup$

Posting this question again and maybe I'll find any help this time. So, recently I was trying to port model from Mass Effect, this model is a helmet on the image below.enter image description here

So, the problem is that I had to apply the texture on it using Blender Game Engine, not the cycles or Blender Render. And the outcome after UV mapping the helmet resulted in this:enter image description hereenter image description here Can someone please tell me what I had to do to get rid of it? I am just losing hope atm. It worked fine in the Cycles but not in the Blender Game engine.

Any pieces of advice would be helpful!

$\endgroup$
1
$\begingroup$

Judging by the images you posted, this is probably what's wrong with you scene.

Flipped normals

enter image description here

Steps to fix:-

1. Select your object and go to edit mode

2. Move over to the shadings and UV tab

3. Select everything in your mesh

4. Click on recalculate

enter image description here

5. Go to properties panel and find the shading section and turn off Backface culling

Explanation:-

What Backface culling does is cull or clip the back sides of the face, and the back side is determined by the normals. Your model, judging from the picture, has its normals flipped inside out, and you have backface culling on therefore it's culling all the backfaces. If recalculation does not work, then it means some of the faces are flipped unevenly, thus they need to be manually flipped by using the Flip Direction button in the same shading panel in the tools tab region.

$\endgroup$
0
$\begingroup$

Hey got something for you! You need to reverse the normals of the model.

Select the mesh and go into Edit Mode. Select all of the mesh vertices by clicking the A key, click Mesh > Normals > Flip Normals. Go back into Object Mode and then you're set!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.