I'm making a short walk animation with a robot I modeled myself, but when I try to render out my work it doesn't show up. I have tried the following solutions

1 Camera icon is disabled in the outliner

2 Render layer not showing in the compositor

3 Render layer does not include scene layer or the objects are in a layer that is not renderable.

4 Scene layer not selected

5 Cycles camera visibility disabled in object settings

6 Cycles material disables visibility to the camera

7 Objects are not within the range set by the camera clipping

8 Using the wrong scene

9 Strips present in the VSE, and the sequencer box is enabled in the post process section

10 Cycles: Exposure setting in the film section set to 0

11 Depth of field not set properly making the whole scene blurry

12 Object blocking the camera view

13 An object has been set as the active camera.

14 There are no lights on the scene or they are on a different layer. Objects have no faces.

15 The Solidify modifier takes over the object and is disabled in Viewport

16 Duplication type set to 'Group' and no group is selected.

17 Duplication issues (under the Object tab in the properties panel), e.g., duplication type is not 'None', and object has no children, or set to 'Group' and no group is selected.

I have checked all of these options, but none of them are the issue

  • $\begingroup$ Please provide the blendfile, if you can. blend-exchange.giantcowfilms.com $\endgroup$
    – Retrax
    Jan 22, 2018 at 15:35
  • $\begingroup$ I doubt there was invented new way to block renderability of an object; in all the cases before it was caused by inproper checking of existing options. If you really think you checked everything share a file using a link posted in the comment above $\endgroup$
    – Mr Zak
    Jan 22, 2018 at 16:49
  • 1
    $\begingroup$ Thanks for sharing all of the things you have tried, without more information on your file is going to be very hard to help. Please edit your question and add imahe's or other info you think useful. Consider sharing your file. $\endgroup$
    – user1853
    Jan 22, 2018 at 17:03
  • 1
    $\begingroup$ Without seeing any images, or inspecting a sample file it is difficult to help. Please edit your question again and add either (or both) pieces of information so that it is easier to help you. $\endgroup$
    – Timaroberts
    Jan 23, 2018 at 6:50

1 Answer 1


Judging by the limited info you have put out in your questions, for blender-render these two remaining things might be the reasons why it's not appearing in your final render.

Draw type set to something other than solid or textured and duplication settings is set to anything other than none

enter image description here

Try setting it to textured and none

Something's wrong in the Render layer settings

enter image description here

Maybe you accidentally turned off the renderlayer or the solid option in the Render settings.


Not the answer you're looking for? Browse other questions tagged .