0
$\begingroup$

I often make small mistakes when extruding geometry for example when extruding walls for a house. Sometimes this creates double geometry. I know I can get rid of this using W > remove doubles. In this case I can't seem to get rid of this faulty geomtry (see screenshot). Somehow, these 3 vertices seem connected with a plane that I didn't create. I tried Remove Doubles, Dissolve, Delete etc... but nothing works.

Can someone tell me how to clean these problems please? Thank you.

enter image description here

$\endgroup$
  • $\begingroup$ It may be the face of a non-planar n-gon. Could you check the nearby faces? $\endgroup$ – Carlo Jan 21 '18 at 20:24
  • 1
    $\begingroup$ There is indeed a non-planar face. When I go to face selection, I can select that whole corner as one face, which doesn't make sense. I think the mistake was caused by extruding everyting downwards. Is it possible to clean this up or should I just delete the whole thing? $\endgroup$ – skullforger Jan 21 '18 at 20:44
  • $\begingroup$ in face select mode select that triangle and delete it. $\endgroup$ – cegaton Jan 22 '18 at 0:02
  • $\begingroup$ You try selecting everything in Edit Mode, then Press W and select the Remove doubles option. $\endgroup$ – Tejas Jan 22 '18 at 0:25
  • $\begingroup$ @cegaton, the triangle is not recognised as a face $\endgroup$ – skullforger Jan 22 '18 at 20:40
1
$\begingroup$

I can't see a lot from your image but this might be just a big n-gon, so maybe you can try selecting these two vertices marked in red and pressing J to create a line.
(it will probably solve it by completing the box shape)

enter image description here

$\endgroup$
  • $\begingroup$ Thanks, I had to do some more deleting and redrawing but your tip got me on the right track. $\endgroup$ – skullforger Jan 22 '18 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.